Networking (POJ - 1287)(并查集+最小生成树)

11 篇文章 0 订阅
9 篇文章 0 订阅

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area. 
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.
Input
The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line. 
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i. 
Output
For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.
Sample Input
1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0
Sample Output
0
17
16
26

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
int f[100];//并查集 
struct note
{
	int a,b,c;
}tree[100010];
bool cmp(struct note t1,struct note t2)
{
	return t1.c<t2.c;
}

int getf(int v)//查找父节点 
{
	int r=v;
	while(r!=f[r])
	{
		r=f[r];
	}
	f[v]=r;//路径压缩 
	return r;
}
int mergef(int u,int v)//合并父节点 
{
	int t1=getf(u);
	int t2=getf(v);
	if(t1!=t2)
	{
		f[t1]=t2;
		return 1;
	}
	else
	return 0;
}

int main(void)
{
	int n,m;
	while(~scanf("%d",&n))
	{
		if(n==0)
		break; 
		scanf("%d",&m);
		int a,b,c;
		for(int i=0;i<m;i++){
			scanf("%d %d %d",&tree[i].a,&tree[i].b,&tree[i].c);
		}
		sort(tree,tree+m,cmp);//排序,使得权值小的路径在前 
		
		for(int i=1;i<=n;i++)//并查集初始化 
		f[i]=i;
		
		int sum=0;
		int step=0;
		for(int i=0;i<m;i++)//按权值从小到大枚举每一条路 
		{
			if(mergef(tree[i].a,tree[i].b))//如果这两个点之间还没有路 
			{
				sum+=tree[i].c;//更新生成树总长度 
				step++;
				if(step==n-1)//如果选够了n-1条路则退出循环 
				break;
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值