F - A Bug's Life (分类并查集)

16 篇文章 0 订阅
9 篇文章 0 订阅

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int f[2010],s[2010];

void init(int n)
{
	for(int i=0;i<=n;i++)
	f[i]=i;
	memset(s,0,sizeof(s));
}
int getf(int u)
{
	if(f[u]==u)
	return u;
	return f[u]=getf(f[u]);
}
bool merge(int u,int v)
{
	int t1=getf(u);
	int t2=getf(v);
	if(t1==t2)
	return false;
	f[t2]=t1;
	return true;
}

int main(void)
{
	int t,k=0;
	ios::sync_with_stdio(false);
	cin>>t;
	while(t--)
	{
		int n, m;
		cin>>n>>m;
		init(n);
		int u,v,t1,t2;
		int flag=0;
		for(int i=1;i<=m;i++)
		{
			cin>>u>>v;
			if(flag)
			continue;
			t1=getf(u);
			t2=getf(v);
			if(t1==t2)
			{
				flag=1;
				continue;
			}
			//以下操作把同类虫子连接起来 
			if(s[u]==0)
			s[u]=v;
			else
			merge(s[u],v);//若u已经有对象则把u原来的对象和现在的对象归为同一类 
			//不用担心u的旧对象和新对象是否是同一性别,因为前面的t1==t2已经确定了u和u现在的对象不可能是同一性别 
			if(s[v]==0)
			s[v]=u;
			else
			merge(s[v],u);
		}
		cout<<"Scenario #"<<++k<<":"<<endl;
		if(flag)
		cout<<"Suspicious bugs found!"<<endl<<endl;
		else
		cout<<"No suspicious bugs found!"<<endl<<endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值