ACM - A Bug's Life

A Bug’s Life

Background:
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem:
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output
The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.

Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

种类并查集:
此题是(ACM - 食物链)的弱化版,bug只有两种性别,而输入的信息并没有明确指定是哪一种性别,故需要将father数组定义为两倍
1.在unit()函数联合块时,需要将可能的关系unit完整.
2.在find查找头目以确定同类关系时,只对对应的x, y一次就行。

代码:

#include <cstring>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <string>
#include <queue>
#include <deque>
#include <stack>
#include <map>
#include <set>
#include <vector>
#define INF  0x3f3f3f3f
#define mod 998244353
#define PI acos(-1)
using namespace std;
typedef long long ll;
const int maxn = 2000;
int fa[maxn * 2 + 5];
inline int find(int x)
{
	int r = x, q;
	while (r != fa[r])
		r = fa[r];
	// 路径压缩
	while (x != r)
	{
		q = fa[x];
		fa[x] = fa[q];
		x = q;
	}
	return r;
}
inline void unit(int x, int y)
{
	int a = find(x);
	int b = find(y);
	fa[b] = a;
}
int main()
{
	int s, n, m, cnt = 0;
	cin >> s;
	while (s--)
	{
		cin >> n >> m; // n只虫子,m次实验
		for (int i = 1; i <= 2 * n; i++) 
			fa[i] = i;  // fa数组初始化!!
		int flag = 0;
		for (int i = 1; i <= m; i++)
		{
			int x, y;
			cin >> x >> y;
			if (find(x) == find(y)) flag = 1;
			else {
				unit(x, y + n);
				unit(y, x + n);
			}
		}
		if (flag) printf("Scenario #%d:\nSuspicious bugs found!\n\n", ++cnt);
		else printf("Scenario #%d:\nNo suspicious bugs found!\n\n", ++cnt);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值