I - Cow Contest POJ - 3660

I - Cow Contest

 POJ - 3660 

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M(1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

只要与其余n-1个比赛过,那就能确定他的位置,。。

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<queue>
using namespace std;
const int N = 107;
const int M = 10007;
int a[N][N];


int main(){
	
	int n, m;
	while (~scanf("%d %d", &n, &m)) {
		
		for (int i = 1; i <= n; ++i){
			for (int j = 1; j <= n; ++j) {
				a[i][j] = 0;
			}
		}
		int u, v;
		for (int i = 1; i <= m; ++i) {
			scanf ("%d %d", &u, &v);
			a[u][v] = 1;
		}
		for (int k = 1; k <= n; ++k) { //求出所有能到达的点,别的到他,或者他到别的 
			for (int i = 1; i <= n; ++i) {
				for (int j = 1; j <= n; ++j) {
					if (!a[i][j] && a[i][k] && a[k][j]) {
						a[i][j] = 1;
					}
				}
			}
		}
		int ans = 0;
		for (int i = 1; i <= n; ++i) {
			int count = 0;
			for (int j = 1; j <= n; ++j) {
				if (a[i][j] || a[j][i]) {
					count++;
				}
			}
			if (count == n-1) {
				ans++;
			}
		}
		printf ("%d\n", ans);
	}
	
	return 0;
} 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值