Cow Contest---牛的比赛

http://poj.org/problem?id=3660

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤B ≤ NA ≠ B), then cow A will always beat cowB.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

 

题意:

是给出m对牛的相互关系,求有多少个牛排名是确定的。

方法:floyed

如果一个牛和其余的牛关系都是确定的,那么这个牛的排名就是确定的了~

 这个题有个注意点,在ac上有显示~

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int d[110][110];
int a,b;
int main()
{
    int n,m;
    while(~scanf("%d %d",&n,&m))
    {
        memset(d,0,sizeof(d));
        for(int i=1; i<=m; i++)
        {
            scanf("%d %d",&a,&b);
            d[a][b]=1;           ///有关系为1
        }
        for(int k=1; k<=n; k++)///1 ≤ A ≤ N; 1 ≤ B ≤ N; 
        {
            for(int i=1; i<=n; i++)///循环中不能从0~n-1只能1~n!!!
            {
                for(int j=1; j<=n; j++)
                {
                    d[i][j]=d[i][j]||(d[i][k]&&d[k][j]);///有关系
                }
            }
        }
        int ans=0;
        for(int i=1; i<=n; i++)
        {
            int sum=0;
            for(int j=1; j<=n; j++)
            {
                if(d[i][j]||d[j][i])
                    sum++;
            }
            if(sum==n-1)          ///和n-1个有关系,就能确定位置
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

如果会出现奇迹,那一定是努力的另一个名字~!

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

嵩韵儿

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值