Rain on your Parade HDU - 2389 (二分匹配,Hopcroft-Karp算法)

9 篇文章 0 订阅
9 篇文章 0 订阅

Rain on your Parade

 HDU - 2389 

You’re giving a party in the garden of your villa by the sea. The party is a huge success, and everyone is here. It’s a warm, sunny evening, and a soothing wind sends fresh, salty air from the sea. The evening is progressing just as you had imagined. It could be the perfect end of a beautiful day. 
But nothing ever is perfect. One of your guests works in weather forecasting. He suddenly yells, “I know that breeze! It means its going to rain heavily in just a few minutes!” Your guests all wear their best dresses and really would not like to get wet, hence they stand terrified when hearing the bad news. 
You have prepared a few umbrellas which can protect a few of your guests. The umbrellas are small, and since your guests are all slightly snobbish, no guest will share an umbrella with other guests. The umbrellas are spread across your (gigantic) garden, just like your guests. To complicate matters even more, some of your guests can’t run as fast as the others. 
Can you help your guests so that as many as possible find an umbrella before it starts to pour? 

Given the positions and speeds of all your guests, the positions of the umbrellas, and the time until it starts to rain, find out how many of your guests can at most reach an umbrella. Two guests do not want to share an umbrella, however. 

Input

The input starts with a line containing a single integer, the number of test cases. 
Each test case starts with a line containing the time t in minutes until it will start to rain (1 <=t <= 5). The next line contains the number of guests m (1 <= m <= 3000), followed by m lines containing x- and y-coordinates as well as the speed si in units per minute (1 <= s i <= 3000) of the guest as integers, separated by spaces. After the guests, a single line contains n (1 <= n <= 3000), the number of umbrellas, followed by n lines containing the integer coordinates of each umbrella, separated by a space. 
The absolute value of all coordinates is less than 10000. 

Output

For each test case, write a line containing “Scenario #i:”, where i is the number of the test case starting at 1. Then, write a single line that contains the number of guests that can at most reach an umbrella before it starts to rain. Terminate every test case with a blank line. 

Sample Input

2
1
2
1 0 3
3 0 3
2
4 0
6 0
1
2
1 1 2
3 3 2
2
2 2
4 4

Sample Output

Scenario #1:
2

Scenario #2:
2
#include <algorithm>
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <queue>
#include <cmath>
using namespace std;
const int N = 3007;
const int INF = 0x3f3f3f3f;
int dx[N], dy[N], mx[N], my[N], in[N], dis; 
vector<int> g[N];

bool bfs(int n) {
	queue<int> q;
	dis = INF;
	memset(dx, -1, sizeof(dx));
	memset(dy, -1, sizeof(dy));
	for (int i = 1; i <= n; ++i) {
		if (mx[i] == -1) { //所有未匹配点 
			q.push(i);
			dx[i] = 0; //为源点 (计算各个点到源点的距离) 
		}
	}
	while (!q.empty()) { 
		int u = q.front(); q.pop();
		if (dx[u] > dis) break; // ??? // 已经找到一条增广路 
		int m = g[u].size();
		for (int i = 0; i < m; ++i) {
			int v = g[u][i];
			if (dy[v] == -1) {
				dy[v] = dx[u] + 1;
				if (my[v] == -1) {
					dis = dy[v];
				} else {
					dx[my[v]] = dy[v] + 1;
					q.push(my[v]);
				}
			}
		}
	}
	return dis != INF;
} 

int dfs(int u) {
	int m = g[u].size();
	for (int i = 0; i < m; ++i) {
		int v = g[u][i];
		if (!in[v] && dy[v] == dx[u] + 1) {
			in[v] = 1;
			if (my[v] != -1 && dy[v] == dis) continue; //v已有匹配且 增广路没了?
			if (my[v] == -1 || dfs(my[v])) {
				my[v] = u;
				mx[u] = v;
				return 1;
			} 
		}
	}
	return 0;
}

double juli(double x, double y, double x0, double y0) {
	return (x - x0) * (x - x0) + (y - y0) * (y - y0);
}

int main() {
	int T, t = 1;
	scanf ("%d", &T);
	while (T--) {
	 	
		int time, m;
		int x[N], y[N], s[N];
		scanf ("%d %d", &time, &m);
		for (int i = 1; i <= m; ++i){
			scanf ("%d %d %d", &x[i], &y[i], &s[i]);
		}
		int n;
		scanf ("%d", &n);
		int a[N], b[N];
		for (int i = 1; i <= n; ++i) {
			scanf ("%d %d", &a[i], &b[i]);
		}
		for (int i = 1; i <= m; ++i) g[i].clear();
		for (int i = 1; i <= m; ++i) {
			double dist = s[i] * time;
			dist *= dist;
			for (int j = 1; j <= n; ++j) {
				if (juli(x[i], y[i], a[j], b[j]) <= dist) {
					g[i].push_back(j);
				}
			}
		}
		int ans = 0;
		memset(mx, -1, sizeof(mx)); // n
		memset(my, -1, sizeof(my));
		while (bfs(m)) {
			memset(in, 0, sizeof(in));
			for (int i = 1; i <= m; ++i) {
				if (mx[i] == -1 && dfs(i)) ++ans;
			}
		}
		printf ("Scenario #%d:\n%d\n\n", t++, ans);
	}
	
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值