hdu2389---Rain on your Parade(二分图匹配—HK算法)

Rain on your Parade

Problem Description
You’re giving a party in the garden of your villa by the sea. The party is a huge success, and everyone is here. It’s a warm, sunny evening, and a soothing wind sends fresh, salty air from the sea. The evening is progressing just as you had imagined. It could be the perfect end of a beautiful day.
But nothing ever is perfect. One of your guests works in weather forecasting. He suddenly yells, “I know that breeze! It means its going to rain heavily in just a few minutes!” Your guests all wear their best dresses and really would not like to get wet, hence they stand terrified when hearing the bad news.
You have prepared a few umbrellas which can protect a few of your guests. The umbrellas are small, and since your guests are all slightly snobbish, no guest will share an umbrella with other guests. The umbrellas are spread across your (gigantic) garden, just like your guests. To complicate matters even more, some of your guests can’t run as fast as the others.
Can you help your guests so that as many as possible find an umbrella before it starts to pour?

Given the positions and speeds of all your guests, the positions of the umbrellas, and the time until it starts to rain, find out how many of your guests can at most reach an umbrella. Two guests do not want to share an umbrella, however.

Input
The input starts with a line containing a single integer, the number of test cases.
Each test case starts with a line containing the time t in minutes until it will start to rain (1 <=t <= 5). The next line contains the number of guests m (1 <= m <= 3000), followed by m lines containing x- and y-coordinates as well as the speed si in units per minute (1 <= si <= 3000) of the guest as integers, separated by spaces. After the guests, a single line contains n (1 <= n <= 3000), the number of umbrellas, followed by n lines containing the integer coordinates of each umbrella, separated by a space.
The absolute value of all coordinates is less than 10000.

Output
For each test case, write a line containing “Scenario #i:”, where i is the number of the test case starting at 1. Then, write a single line that contains the number of guests that can at most reach an umbrella before it starts to rain. Terminate every test case with a blank line.

Sample Input
2
1
2
1 0 3
3 0 3
2
4 0
6 0
1
2
1 1 2
3 3 2
2
2 2
4 4

Sample Output
Scenario #1:
2

Scenario #2:
2

题意是有m个人,n把伞,给出了每个人的位置及速度,还有每把伞的位置,让我们求在给定的时间内最多能有多少人可以拿到伞。

也是一道一眼就能看出来的二分图最大匹配的题目,但是用匈牙利算法(时间复杂度为O(n*m))会超时,一开始做这道题我也直接莽了一发匈牙利果然超时了,后来了解到了Hopcroft-Karp算法(时间复杂度为O(n^(1/2)*m))。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#include<queue>
#include<iostream>
#include<algorithm>
using namespace std;

#define maxn 3010
#define ll long long
#define inf 0x3f3f3f3f
#define mod 998244353

struct node
{
    double x,y,s;
} a[maxn];

struct Node
{
    double x,y;
} b[maxn];

int link[maxn][maxn],vis[maxn],cx[maxn],cy[maxn],dx[maxn],dy[maxn];
int n,m,t,Case=1,dis;

bool searchpath()
{
    queue<int>q;
    dis=inf;
    memset(dx,-1,sizeof(dx));
    memset(dy,-1,sizeof(dy));
    for(int i=1; i<=m; i++)
    {
        if(cx[i]==-1)
        {
            q.push(i);
            dx[i]=0;
        }
    }
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        if(dx[u]>dis) break;
        for(int i=1; i<=n; i++)
        {
            if(link[u][i]&&dy[i]==-1)
            {
                dy[i]=dx[u]+1;
                if(cy[i]==-1) dis=dy[i];
                else
                {
                    dx[cy[i]]=dy[i]+1;
                    q.push(cy[i]);
                }
            }
        }
    }
    return dis!=inf;
}

int dfs(int u)
{
    for(int i=1; i<=n; i++)
    {
        if(link[u][i]&&!vis[i]&&dy[i]==dx[u]+1)
        {
            vis[i]=1;
            if(cy[i]!=-1&&dy[i]==dis)
                continue;
            if(cy[i]==-1||dfs(cy[i]))
            {
                cx[u]=i;
                cy[i]=u;
                return 1;
            }
        }
    }
    return 0;
}

int maxmatch()
{
    memset(cx,-1,sizeof(cx));
    memset(cy,-1,sizeof(cy));
    int res=0;
    while(searchpath())
    {
        memset(vis,0,sizeof(vis));
        for(int i=1; i<=m; i++)
        {
            if(cx[i]==-1)
                res+=dfs(i);
        }
    }
    return res;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(link,0,sizeof(link));
        scanf("%d %d",&t,&m);
        for(int i=1; i<=m; i++)
            scanf("%lf %lf %lf",&a[i].x,&a[i].y,&a[i].s);
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
            scanf("%lf %lf",&b[i].x,&b[i].y);
        for(int i=1; i<=m; i++)
            for(int j=1; j<=n; j++)
            {
                if(a[i].s*t>=sqrt((a[i].x-b[j].x)*(a[i].x-b[j].x)+(a[i].y-b[j].y)*(a[i].y-b[j].y)))
                    link[i][j]=1;
            }
        int ans=maxmatch();
        printf("Scenario #%d:\n",Case++);
        printf("%d\n\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值