Stealing Harry Potter's Precious HDU - 4771 (BFS+状态压缩dp)

14 篇文章 0 订阅
9 篇文章 0 订阅

Stealing Harry Potter's Precious

 HDU - 4771 

 Harry Potter has some precious. For example, his invisible robe, his wand and his owl. When Hogwarts school is in holiday, Harry Potter has to go back to uncle Vernon's home. But he can't bring his precious with him. As you know, uncle Vernon never allows such magic things in his house. So Harry has to deposit his precious in the Gringotts Wizarding Bank which is owned by some goblins. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1)..... A 3×4 bank grid is shown below: 



  Some rooms are indestructible and some rooms are vulnerable. Goblins always care more about their own safety than their customers' properties, so they live in the indestructible rooms and put customers' properties in vulnerable rooms. Harry Potter's precious are also put in some vulnerable rooms. Dudely wants to steal Harry's things this holiday. He gets the most advanced drilling machine from his father, uncle Vernon, and drills into the bank. But he can only pass though the vulnerable rooms. He can't access the indestructible rooms. He starts from a certain vulnerable room, and then moves in four directions: north, east, south and west. Dudely knows where Harry's precious are. He wants to collect all Harry's precious by as less steps as possible. Moving from one room to another adjacent room is called a 'step'. Dudely doesn't want to get out of the bank before he collects all Harry's things. Dudely is stupid.He pay you $1,000,000 to figure out at least how many steps he must take to get all Harry's precious.

Input

  There are several test cases. 
  In each test cases: 
  The first line are two integers N and M, meaning that the bank is a N × M grid(0<N,M <= 100). 
  Then a N×M matrix follows. Each element is a letter standing for a room. '#' means a indestructible room, '.' means a vulnerable room, and the only '@' means the vulnerable room from which Dudely starts to move. 
  The next line is an integer K ( 0 < K <= 4), indicating there are K Harry Potter's precious in the bank. 
  In next K lines, each line describes the position of a Harry Potter's precious by two integers X and Y, meaning that there is a precious in room (X,Y). 
  The input ends with N = 0 and M = 0 

Output

  For each test case, print the minimum number of steps Dudely must take. If Dudely can't get all Harry's things, print -1. 

Sample Input

2 3
##@
#.#
1
2 2
4 4
#@##
....
####
....
2
2 1
2 4
0 0

Sample Output

-1
5

题意:给定一张n*m地图,'.'能走,‘#’不能走,@是出发点,然后再给k个坐标点,问走完所有目标点的最短路径,如果不能走完则输出-1.

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue> 
using namespace std;
const int N = 111;
char g[N][N]; // 地图 
int vis[N][N]; //标记 //这里没有用到 
int dp[N][N][16]; //dp[x][y][state]:在(x,y)处的state状态是否走过 
int dx[] = {1, 0, -1, 0}, dy[] = {0, 1, 0, -1}; // 四个方向 
int n, m; //n*m地图 
struct Node {
	int x, y, s;
	Node() : x(0), y(0), s(0){} 
	Node(int xx, int yy, int ss) {
		x = xx, y = yy, s = ss;
	}
};
//Start:起点, tn:目标点个数, tar[][]:目标点坐标 
int bfs(Node& Start, int& tn, vector<vector<int> >& tar) {
	queue<Node> q;
	Start.s = 0;
	for (int i = 1; i <= tn; ++i) { //考虑目标点就在起点的情况 
		if (Start.x == tar[i][1] && Start.y == tar[i][2]) {
			Start.s |= (1 << (i-1)); //第i位置1表示第i个目标已经到达
		}
	}
	q.push(Start);
	memset(dp, -1, sizeof(dp));
	dp[Start.x][Start.y][Start.s] = 0;
	while (!q.empty())  {
		Node now = q.front(); q.pop();
		if (now.s == ((1<<tn) - 1)) {//tn个1,表示所有目标已经找到 
			return dp[now.x][now.y][now.s]; 
		} 
		for (int i = 0; i < 4; ++i) { //遍历四个方向 
			int xx = now.x + dx[i];
			int yy = now.y + dy[i];
			int ss = now.s;  //目标状态!!只复制不改变,还要用 
			if (xx < 1 || xx > n || yy < 1 || yy > m) continue; //地图边界
			if (g[xx][yy] == '#') continue; //地图障碍
			for (int j = 1; j <= tn; ++j) {
				if (xx == tar[j][1] && yy == tar[j][2]) { //i&j不能混乱 
					ss |= (1<<(j-1)); //第j位置1 
				}
			} 
			if (dp[xx][yy][ss] != -1) continue; //已经到过此状态
			dp[xx][yy][ss] = dp[now.x][now.y][now.s] + 1;
			q.push(Node(xx, yy, ss)); //ss 和 now.s 不能混用!! 
		}
	}
	return -1; //不能到达所有目标 
} 

int main() {
	while (~scanf ("%d %d", &n, &m) && (n+m)) {
		
		for (int i = 1; i <= n; ++i) {
			scanf ("%s", g[i]+1);
		}
		memset(vis, -1, sizeof(vis));
		Node start_point; //开始点 
		for (int i = 1; i <= n; ++i) {
			for (int j = 1; j <= m; ++j) {
				if (g[i][j] == '@') { // 开始点 
					start_point.x = i, start_point.y = j;
					i = n; break; //快速结束两重循环 
				}
			}
		} 
		int k; //目标点个数 
		scanf ("%d", &k); 
		vector<vector<int> > tar(k+1, vector<int>(3)); //存放目标点坐标 
		for (int i = 1; i <= k; ++i) {
			scanf ("%d %d", &tar[i][1], &tar[i][2]);
		} 
		int ans = bfs(start_point, k, tar);
		printf ("%d\n", ans);
	}
	return 0;
} 

 

Work-Stealing Queue是一种用于并发编程的数据结构,它允许多个线程在共享队列上执行工作项,其中每个线程维护自己的任务队列,并且当自己的队列为空时,可以从其他线程的队列中“偷”一些工作项来执行。该数据结构适用于任务量不确定、任务执行时间较长的情况。 下面是一个使用Work-Stealing Queue实现顺序执行的简单代码示例: ```c++ #include <iostream> #include <thread> #include <vector> #include "taskflow/taskflow.hpp" void func1() { std::cout << "Function 1" << std::endl; } void func2() { std::cout << "Function 2" << std::endl; } void func3() { std::cout << "Function 3" << std::endl; } int main() { tf::Executor executor; tf::Taskflow taskflow; // 将三个函数作为任务添加到taskflow中 auto task1 = taskflow.emplace([]() { func1(); }); auto task2 = taskflow.emplace([]() { func2(); }); auto task3 = taskflow.emplace([]() { func3(); }); // 任务之间的依赖关系,保证顺序执行 task1.precede(task2); task2.precede(task3); // 将taskflow提交给executor执行 executor.run(taskflow).wait(); return 0; } ``` 在上面的示例中,我们使用`Taskflow`库来创建一个`taskflow`对象,并将三个函数作为任务添加到其中。然后,我们使用`precede`方法来定义任务之间的依赖关系,以确保它们按照正确的顺序执行。最后,我们将`taskflow`提交给`executor`执行,并等待任务完成。 这样,我们就可以实现一个函数一个函数顺序执行的效果。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值