Graveyard Design POJ - 2100 尺取

Graveyard Design

 POJ - 2100 

King George has recently decided that he would like to have a new design for the royal graveyard. The graveyard must consist of several sections, each of which must be a square of graves. All sections must have different number of graves. 
After a consultation with his astrologer, King George decided that the lengths of section sides must be a sequence of successive positive integer numbers. A section with side length s contains s 2 graves. George has estimated the total number of graves that will be located on the graveyard and now wants to know all possible graveyard designs satisfying the condition. You were asked to find them.

Input

Input file contains n --- the number of graves to be located in the graveyard (1 <= n <= 10 14 ).

Output

On the first line of the output file print k --- the number of possible graveyard designs. Next k lines must contain the descriptions of the graveyards. Each line must start with l --- the number of sections in the corresponding graveyard, followed by l integers --- the lengths of section sides (successive positive integer numbers). Output line's in descending order of l.

Sample Input

2030

Sample Output

2
4 21 22 23 24
3 25 26 27
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <utility>
using namespace std;

pair<int, int> p[1000007];
long long pow_(long long s) {
	return s*s;
}
int main() {
	long long n;
	while (~scanf ("%lld", &n)) {
		int ans = 0;
		long long tail = 1, head = 0;
		long long sum = 0;
		while (1) {
			while (sum < n && pow_(head+1) <= n) sum += pow_(++head);
			if (sum < n) break;
			if (sum == n) {
				p[++ans] = pair<int, int> ((int)tail, (int)head);
			}
			sum -= pow_(tail++);
		}
		printf ("%d\n", ans);
		for (int i = 1; i <= ans; ++i) {
			int se = p[i].second;
			printf ("%d ", se - p[i].first + 1);
			for (int j = p[i].first; j < se; ++j) {
				printf ("%d ", j);
			}
			printf ("%d\n", se);
		}
	}
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值