Graveyard Design POJ - 2100(尺取法)

King George has recently decided that he would like to have a new design for the royal graveyard. The graveyard must consist of several sections, each of which must be a square of graves. All sections must have different number of graves.
After a consultation with his astrologer, King George decided that the lengths of section sides must be a sequence of successive positive integer numbers. A section with side length s contains s 2 graves. George has estimated the total number of graves that will be located on the graveyard and now wants to know all possible graveyard designs satisfying the condition. You were asked to find them.
Input
Input file contains n — the number of graves to be located in the graveyard (1 <= n <= 10 14 ).
Output
On the first line of the output file print k — the number of possible graveyard designs. Next k lines must contain the descriptions of the graveyards. Each line must start with l — the number of sections in the corresponding graveyard, followed by l integers — the lengths of section sides (successive positive integer numbers). Output line’s in descending order of l.
Sample Input
2030
Sample Output
2
4 21 22 23 24
3 25 26 27
思路:这个就是比较简单的尺取问题了。两个指针,记录这两个指针之间的数的平方和。大了就l++,小了就r++.
代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#define ll long long
using namespace std;

const int maxx=1e5+100;
ll n;
vector<ll> p[maxx];

int main()
{
	while(~scanf("%lld",&n))
	{
		ll m=sqrt(n)+10;
		for(int i=0;i<maxx;i++) p[i].clear();
		ll l=1,r=1;
		ll ans=0;
		ll cnt=0;
		while(r<=m)
		{
			if(ans==n)
			{
				for(ll i=l;i<r;i++) p[cnt].push_back(i);
				cnt++;
				ans-=l*l;
				l++;
			}
			else if(ans<n) ans+=r*r,r++;
			else ans-=l*l,l++;
		}
		printf("%lld\n",cnt);
		for(int i=0;i<cnt;i++)
		{
			printf("%d",p[i].size());
			for(int j=0;j<p[i].size();j++) printf(" %lld",p[i][j]);
			printf("\n");
		}
	}
	
	return 0;
}

努力加油a啊,(o)/~

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

starlet_kiss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值