尺取法入门2 poj2100 Graveyard Design

Graveyard Design
Time Limit: 10000MS Memory Limit: 64000K
Total Submissions: 7023 Accepted: 1714
Case Time Limit: 2000MS

Description

King George has recently decided that he would like to have a new design for the royal graveyard. The graveyard must consist of several sections, each of which must be a square of graves. All sections must have different number of graves.
After a consultation with his astrologer, King George decided that the lengths of section sides must be a sequence of successive positive integer numbers. A section with side length s contains s 2 graves. George has estimated the total number of graves that will be located on the graveyard and now wants to know all possible graveyard designs satisfying the condition. You were asked to find them.

Input

Input file contains n --- the number of graves to be located in the graveyard (1 <= n <= 10 14 ).

Output

On the first line of the output file print k --- the number of possible graveyard designs. Next k lines must contain the descriptions of the graveyards. Each line must start with l --- the number of sections in the corresponding graveyard, followed by l integers --- the lengths of section sides (successive positive integer numbers). Output line's in descending order of l.

Sample Input

2030

Sample Output

2
4 21 22 23 24
3 25 26 27

Source



分析:直接用打表法爬的话空间很明显是受不了的,所以我们不妨采用动态生成的方式,因为题目时间比较充裕,所以不用记录之前的生成结果也可以过,这是第二类的尺取法

#include <iostream>
#include <cstdio>
#include <vector>

using namespace std;

vector<long long> record;

vector<long long> play[50000];

int main()
{

    long long n;

    while(cin>>n)
    {
        for(int i=0;i<50000;i++)
        {
            play[i].clear();
        }

        record.clear();

        long long l=1,r=1;
        long long sum=0;
        int ans=0;

        while(l*l<=n)
        {
            while(sum<n && r*r<=n)
            {
                sum+=r*r;
                r++;
            }

            if(sum<n)
            {
                break;
            }

            else if(sum==n)
            {

                for(int i=l;i<r;i++)
                record.push_back(i);

                play[ans].push_back(record.size());

                for(int i=0;i<record.size();i++)
                {
                   play[ans].push_back(record[i]);
                }

                ans++;//方案数增加一次

                record.clear();
            }

            sum-=l*l;
            l++;
        }

        cout<<ans<<endl;

        for(int i=0;i<ans;i++)
        {
            for(int j=0;j<play[i].size();j++)
            {
                printf("%d",play[i][j]);
                if(j!=play[i].size()-1) printf(" ");
            }
            cout<<endl;
        }
    }



    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值