hdu1011(树形dp)

Starship Troopers

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17060    Accepted Submission(s): 4517


Problem Description
You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.
 

Input
The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.
 

Output
For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.
 

Sample Input
  
  
5 10 50 10 40 10 40 20 65 30 70 30 1 2 1 3 2 4 2 5 1 1 20 7 -1 -1
 

Sample Output
  
  
50 7 给一个房间的数目和士兵的数量,一个士兵可以解决20个敌人,从1号房间开始打,然后进入 1所连接的房间,而且必须消灭所有敌人才能够把宝藏拿走!然后问你这些士兵最多能拿走 多少宝藏。 明显的dp问题。但是路径又不唯一,所以得用dfs搜索,累加然后比较久OK的。这似乎就是 树形dp的思想这个人写的不错 有人用前向星保存路径,也有人用vector感觉都不错,但是个人觉得vector方便一点。 dp[x][j]=max(dp[x][j],dp[x][j-k]+dp[t][k]);从1一直往下搜,然后把每一段加起来 。。。
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <algorithm>
#include <vector>
using namespace std;
const int len=110;
int n,m;
int bug[len],value[len];
bool vis[len];
int dp[len][len];
vector <int > vec[len];
void dfs(int x)
{
    int temp=(bug[x]+19)/20;//不能写成(bud[x]-1)/20+1!!!!减得时候有时候会错掉!
    for(int i=temp;i<=m;i++)
      dp[x][i]=value[x];//到x房间后获得的宝藏(之后如果这段更优,就会把它接起来)
      vis[x]=1;
      for(int i=0;i<vec[x].size();i++)
      {
          int t=vec[x][i];//x点下能通到的各个路口
          if(vis[t])
            continue;
          dfs(t);
          for(int j=m;j>=temp;j--)//开始累加,因为最后一定会消耗最多的士兵从而获得最多的宝藏
           for(int k=1;k<=j-temp;k++)//留temp个人在当前的房间
            dp[x][j]=max(dp[x][j],dp[x][j-k]+dp[t][k]);//把在k房间获得的利益接到上一个状态上,与当前状态比较
      }
      return ;
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF&&n!=-1&&m!=-1)
    {
        for(int i=0;i<=n;i++)
            vec[i].clear();
        memset(vis,0,sizeof(vis));
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            scanf("%d%d",&bug[i],&value[i]);
        for(int i=1;i<n;i++)
            {
                int p,q;
                scanf("%d%d",&p,&q);
                vec[p].push_back(q);
                vec[q].push_back(p);
            }
        if(m==0)//先初始化再判断!!!!
        {
            printf("0\n");
            continue;
        }
        dfs(1);
         printf("%d\n",dp[1][m]);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值