Crossing River

Crossing River

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.
Output
For each test case, print a line containing the total number of seconds required for all the N people to cross the river.
Sample Input
1
4
1 2 5 10
Sample Output
17

/******************************
题意:T组测试数据,每组有n个人,他们要过河,只有一艘船,每艘船最多载两个人,他们每个人单独划船过河花费的时间不一,并且每当两个人划船过河时,划船速度由慢的人决定,求所有人过河需要的最短时间。

题解:实例 1 2 5 10,首先 1 2 过去耗时为2,1 再回来,耗时为1,5 10 再过去,耗时为10,2 再回来,耗时为2,最后1和2过去,耗时为2,总的耗时为17。首先sort排序,当n=1时,耗时为a1;当n=2时,耗时为a2;当n=3时,耗时为a1+a2+a3;当n>3*时,判断若a[2]*2<a[1]+a[n-1]时,耗时a[1]+2*a[2]+a[n],此操作有来回划船两次,a1和a2过岸,a1再回来,an和an-1过
岸,a2再回来,目的是将最大的两个运到对岸,所以n-=2;若a[2]*2>=a[1]+a[n-1],耗时2*a[1]+a[n]+a[n-1],此操作也是
来回划船两次,目的是用a1携带两个最大的过岸,同样你n-=2。直到n<=3。
******************************/


#include<iostream>
#include<algorithm>
#include<queue>
#include<cstring>
#include<cstdio>
//#include<mm_malloc.h>
#include<map>
#include<climits>
#define MT(a,b) memset(a,b,sizeof(a))
#define ll long long
using namespace std;
const int maxn = 1e3+5;
ll a[maxn],n;

int main()
{
    int T;cin>>T;
    while(T--)
    {
        int n;cin>>n;
        for(int i=1;i<=n;i++)cin>>a[i];
        sort(a+1,a+n+1);
        int sum=0;
        while(n>3)
        {
            if(a[2]*2<a[1]+a[n-1])
                sum+=a[1]+2*a[2]+a[n];
            else
                sum+=2*a[1]+a[n]+a[n-1];
            n-=2;
        }
        if(n==3)sum+=a[3]+a[2]+a[1];
        else if(n==2)sum+=a[2];
        else if(n==1)sum+=a[1];
        cout<<sum<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值