(蓝桥杯)试题 算法训练 最大最小公倍数

试题 算法训练 最大最小公倍数

资源限制
时间限制:1.0s 内存限制:256.0MB
问题描述
已知一个正整数N,问从1~N中任选出三个数,他们的最小公倍数最大可以为多少。

输入格式
输入一个正整数N。

输出格式
输出一个整数,表示你找到的最小公倍数。
样例输入
9
样例输出
504
数据规模与约定
1 <= N <= 106。

import java.math.BigInteger;
import java.util.Scanner;

public class Main{
    public static void main(String[] args){
        Scanner input = new Scanner(System.in) ;
        int n = input.nextInt() ;
        BigInteger result = new BigInteger("" + 0) ;

        if(n<=2){
            result = new BigInteger("" + n) ;
        }
        if(n%2==1){ //n是奇数,两奇加一偶最大
            result = new BigInteger(n + "").multiply(new BigInteger((n-1) +"")).multiply(new BigInteger((n-2) + "")) ;
        }else{ //n是偶数
            if(n%3==0){
                result = new BigInteger((n-1) + "").multiply(new BigInteger((n-2) +"")).multiply(new BigInteger((n-3) + "")) ;
            }else{
                result = new BigInteger(n + "").multiply(new BigInteger((n-1) +"")).multiply(new BigInteger((n-3) + "")) ;
            }
        }
        System.out.println(result) ;

    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

nuist__NJUPT

给个鼓励吧,谢谢你

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值