Cleaning Shifts

Cleaning Shifts

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

  • Line 1: Two space-separated integers: N and T
  • Lines 2…N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

  • Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input
3 10
1 7
3 6
6 10

Sample Output
2

  • 算法思想:根据贪心策略,要使全部覆盖且所用区间最少,则应首先将所有起点排序,选择每次起点在start左侧,而右端点在右侧最远处,每次更新start,直至end>=T,或者永远小于T

import java.util.Arrays;
import java.util.Scanner;

public class CleaningShifts {
    public static class Interval implements Comparable<Interval>{
        int s, t ;
        public Interval(int s, int t){
            this.s = s ;
            this.t = t ;
        }
        @Override
        public int compareTo(Interval other) { //按起点升序排列
            int x = this.s - other.s ;
            if(x == 0){
                return this.t - other.t ;
            }else{
                return x ;
            }
        }
    }
    public static void main(String[] args){
        Scanner input = new Scanner(System.in) ;
        int N = input.nextInt() ;
        int T = input.nextInt() ;
        Interval [] interval = new Interval [N] ;
        for(int i=0; i<N; i++){
            interval[i] = new Interval(input.nextInt(), input.nextInt()) ;
        }
        Arrays.sort(interval) ;
        int start = 1 ; //每个区间的起点
        int end = 1 ; //每个区间的最右端点
        int count = 1 ; //计算所用的区间数量
        for(int i=0; i<N; i++){
            int s = interval[i].s ; //所有起点中最小的
            int t = interval[i].t ;
            if(i==0 && s>1){ //不是从起点1开始,说明覆盖不了
                break ;
            }
            if(s <= start){ //在起点左侧就覆盖,找其右端
                end = Math.max(end, t) ;
            }else{ //新区间,
                count ++ ;
                start = end + 1 ; //更新起点
                if(s <= start){
                    end = Math.max(end, t) ;
                }else{
                    break ;
                }
            }
            if(end >= T){ //如果全部覆盖,则结束循环
                break ;
            }
        }
        if(end < T){ //覆盖不了
            System.out.println("-1") ;
        }else{ //已覆盖,输出覆盖区间数
            System.out.println(count) ;
        }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

nuist__NJUPT

给个鼓励吧,谢谢你

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值