1054 The Dominant Color 20

该问题描述了一个计算机图像处理的任务,要求从24位颜色信息的像素中找出严格占主导地位的颜色。输入包含图像的分辨率和每个像素的RGB值,输出是最频繁出现的颜色。程序通过读取和计数每种颜色的出现次数,找到占比超过一半的颜色作为答案。
摘要由CSDN通过智能技术生成

1054 The Dominant Color 20

问题描述

Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M M M by N N N (for example, 800 × 600 800×600 800×600), you are supposed to point out the strictly dominant color.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: M ( ≤ 800 ) M (≤800) M(800) and N ( ≤ 600 ) N (≤600) N(600) which are the resolutions of the image. Then N N N lines follow, each contains M M M digital colors in the range [ 0 , 2 24 ) [0,2^{24}) [0,224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:
For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

问题思路

本题大意为:给定一个图片的像素分布,求其中占据主要比例的颜色。

M × N M\times N M×N最多为 800 × 600 800\times 600 800×600,因此不用理会高达 2 24 × 4 B y t e s 2^{24}\times 4 Bytes 224×4Bytes的唬人数据。读入输入的颜色,找出其中出现频率最高的即可。

源码

#include<cstdio>
#include<map>
using namespace std;

int main()
{
    map<int, int> color_porp;
    int M, N, color;
    scanf("%d %d", &M, &N);
    for(int i=0; i<N; i++)
    {
        for(int j=0; j<M; j++)
        {
            scanf("%d", &color);
            if(color_porp.find(color) == color_porp.end()){
                color_porp[color]=1;
            }else{
                color_porp[color]++;
            }
        }
    }

    auto max=color_porp.begin();
    for(auto s=++color_porp.begin(); s != color_porp.end(); s++)
    {
        if(s->second > max->second)
            max = s;
    }
    printf("%d", max->first);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值