1054 The Dominant Color (20 分)

360 篇文章 3 订阅
91 篇文章 1 订阅

Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2
24
). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:
For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

结尾无空行
Sample Output:

24

结尾无空行

大概的意思就是,求数组中出现最多的数,次数要大于数组大小的一半,但是题目中又要求,It is guaranteed that the strictly dominant color exists for each input image,意思是次数一定存在,所以我们甚至都不用判断是否成立,定义一个一维数组即可,排序,使用摩尔投票法,模板要背过,求出出现次数最多的即可,需要注意,题目中有一个 2 的 24 次方,用 int 是肯定会越界的,所以我们选择 long long

#include<iostream>
#include<string>
#include<algorithm>
#include<bits/stdc++.h>
#include<stack>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<deque>
#include<cctype>
#include<unordered_set>
#include<unordered_map>
#include<fstream>
#include<cstring>
using namespace std;
int main() {
	int n, m;
	cin >> n >> m;
	long long int a[n * m + 1];
	int index = 0;
	for (int i = 0; i < n; i++) {
		for (int j = 0; j < m; j++) {
			cin >> a[index++];
		}
	}
	int count = 0;
	long long int result = 0;
	for (int i = 0; i < index; i++) {
		if (count == 0) {
			result = a[i];
		}
		if (result == a[i]) {
			count++;
		} else {
			count--;
		}
	}
	cout << result;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值