杭电1002-A + B Problem II(大数)

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 269506    Accepted Submission(s): 52064


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 


大数相加,挺简单的 ,有一点格式要注意下,每两个测试数据中间要有一个空行,注意!



#include<cstdio>
#include<cstring>
char s1[1000],s2[1000];
int a[1000],b[1000];
int main()
{
	int N,len1,len2,t,i,cot=1;
	scanf("%d",&N);
	while(N--)
	{
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		if(cot!=1)
		printf("\n"); 
		scanf("%s%s",s1,s2);
		printf("Case %d:\n",cot++);	
		len1=strlen(s1);
		len2=strlen(s2);
		t=0;
		for(i=len1-1;i>=0;i--)
		a[t++]=s1[i]-'0';
		t=0;
		for(i=len2-1;i>=0;i--)
		b[t++]=s2[i]-'0';//字符型转化为整形,进行计算
		if(len1<len2)
		{
			t=len2;
			len1=len2;
			len2=t;
		 } 
		for(i=0;i<len1;i++)
		{
			a[i]+=b[i];//按位相加
			if(a[i]>9)//判断是否进位
			{
				a[i+1]++;
				a[i]-=10; 
			}
		}
		for(i=999;a[i]==0;i--);
		printf("%s + %s = ",s1,s2); 
		for(;i>=0;i--)
		printf("%d",a[i]);
		printf("\n");  
	}
	return 0;
} 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值