杭电 大数相加 A+B problem2

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

 

大数相加的注意点是:保存大数的类型

代码:

#include<stdio.h>

#include<string.h>

int main()

{

    int i=0,n=0,l=0,j=1;

    char a[1000],b[1000];//注意大数相加里大数要用字符串表示

    int num1[1000]={0},num2[1000]={0};

    scanf("%d",&n);

    while(n--)

    {

        while(~scanf("%s%s",a,b))

        {

            memset(num1,0,sizeof(num1));//数组清零

            l=strlen(a)-1;

            for(i=0;l>=0;l--,i++)

            {

                num1[i]=a[l]-'0';//将输入的字符串中的数字变为普通//自然数

            }

            memset(num2,0,sizeof(num2)); //数组清零

            l=strlen(b)-1;

            for(i=0;l>=0;l--,i++)

            {

                num2[i]=b[l]-'0';

            }

        //数字相加

            for(i=0;i<1000;i++)

            {

                num1[i]+=num2[i];

                num1[i+1]+=num1[i]/10;

                num1[i]%=10;

            }

       //因为相加的时候是倒着加的为了输出原数字,倒着输出

            int i=999;

            while(!num1[i]) i--;

            if(j!=1)printf("\n");

            printf("Case%d:\n",j++);

            printf("%s + %s =",a,b);

            while(i>=0)

                printf("%d",num1[i--]);

            printf("\n");

        }   

    }

    return 0;

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值