杭电2680-Choose the best route(最短路反向建图)

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10891    Accepted Submission(s): 3529


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
  
  
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
  
  
1 -1
 

这个题用spfa没法判断重边,用floyd会超时,所以只能用dijkstra了,但是,记得要反向建图,因为只有一个终点,多个起点,所以反向建图只需要用一次dijlstra



#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int map[1010][1010],dis[1010],vis[1010];
int m,n,e,s[1010];
void dijkstra()
{
	int i,j,mi,mark;
	memset(vis,0,sizeof(vis));
	for(i=1;i<=m;i++)
		dis[i]=map[e][i];
	vis[e]=1;
	dis[e]=0;
	for(i=0;i<m;i++)
	{
		mi=INF,mark=-1;
		for(j=1;j<=m;j++)
		{
			if(mi>dis[j]&&!vis[j])
			{
				mi=dis[j];
				mark=j;
			}
		}
		if(mark==-1)
		break;
		vis[mark]=1;
		for(j=1;j<=m;j++)
		{
			if(!vis[j]&&dis[j]>dis[mark]+map[mark][j])
			dis[j]=dis[mark]+map[mark][j];
		}
	}
}
int main()
{
	int i,w,a,b,c;
	while(scanf("%d%d%d",&m,&n,&e)!=EOF)
	{
		memset(map,INF,sizeof(map));
		for(i=0;i<n;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			if(map[b][a]>c)
			map[b][a]=c;
		}
		dijkstra();
		scanf("%d",&w);
		int best=INF;
		for(i=0;i<w;i++)
		{
			scanf("%d",&a);
			best=best>dis[a]?dis[a]:best;
		}
		if(best==INF)
		printf("-1\n");
		else
		printf("%d\n",best);
	}
	return 0;
}



下面floyd代码虽然优化了,但是还是超时



#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int map[1010][1010],dis[1010],vis[1010];
int m,n,e,s[1010];
void floyd()
{
	int i,j,k;
	for(i=1;i<=m;i++)
	{
		for(j=1;j<=m;j++)
		{
			if(map[i][j]==INF)
			continue;
			for(k=1;k<=m;k++)
			{
				if(map[j][k]>map[j][i]+map[i][k])
				map[j][k]=map[j][i]+map[i][k];
			}
		}
	}
	
}
int main()
{
	int i,w,a,b,c;
	while(scanf("%d%d%d",&m,&n,&e)!=EOF)
	{
		memset(map,INF,sizeof(map));
		for(i=0;i<n;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			if(map[b][a]>c)
			map[b][a]=c;
		}
		floyd();
		scanf("%d",&w);
		int best=INF;
		for(i=0;i<w;i++)
		{
			scanf("%d",&a);
			best=best>map[e][a]?map[e][a]:best;
		}
		if(best==INF)
		printf("-1\n");
		else
		printf("%d\n",best);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值