杭电-1875畅通工程再续

畅通工程再续

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20923    Accepted Submission(s): 6613


Problem Description
相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。
 

Input
输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。
 

Output
每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.
 

Sample Input
  
  
2 2 10 10 20 20 3 1 1 2 2 1000 1000
 

Sample Output
  
  
1414.2 oh!
 


最小生成树,kruskal!


#include<cstdio> 
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int m,per[500],cot;
struct node {
	int x,y;
	double dis;
}s[10000000];
double distance(int x1,int y1,int x2,int y2)
{
	return double(sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2)*1.0));
}
bool cmp(node x,node y)
{
	return x.dis<y.dis;
}
void init()
{
	for(int i=0;i<m;i++)
	per[i]=i;
}
int find(int x)
{
	int i=x,t=x,j;
	while(t!=per[t])
	t=per[t];
	while(i!=t)
	{
		j=per[i];
		per[i]=t;
		i=j;
	}
	return t;
}
bool join(int x,int y)
{
	int fx=find(x),fy=find(y);
	if(fx!=fy)
	{
		cot++;
		per[fx]=fy;
		return true;
	}
	return false;
}

int main()
{
	int N,n,a[300],b[300],i,j;
	scanf("%d",&N);
	while(N--)
	{
		cot=0;
		scanf("%d",&m);
		init();
		for(i=0;i<m;i++)
			scanf("%d%d",&a[i],&b[i]);
			int t=0;
		for(i=0;i<m;i++)
		{
			for(j=0;j<=i;j++)
			{
				s[t].x=i;
				s[t].y=j;
				double q=distance(a[i],b[i],a[j],b[j]);
				if(q<=1000&&q>=10)
				s[t++].dis=q;
			}
		}
		sort(s,s+t,cmp);
		double sum=0;
		for(i=0;i<t;i++)
		{
			if(join(s[i].x,s[i].y))
			sum+=s[i].dis;
		}
		if(cot!=m-1)
		printf("oh!\n");
		else
		printf("%.1lf\n",sum*100);
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值