POJ 3154 缩放坐标

  
Graveyard
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 1849 Accepted: 919 Special Judge

Description

Programming contests became so popular in the year 2397 that the governor of New Earck — the largest human-inhabited planet of the galaxy — opened a special Alley of Contestant Memories (ACM) at the local graveyard. The ACM encircles a green park, and holds the holographic statues of famous contestants placed equidistantly along the park perimeter. The alley has to be renewed from time to time when a new group of memorials arrives.

When new memorials are added, the exact place for each can be selected arbitrarily along the ACM, but the equidistant disposition must be maintained by moving some of the old statues along the alley.

Surprisingly, humans are still quite superstitious in 24th century: the graveyard keepers believe the holograms are holding dead people souls, and thus always try to renew the ACM with minimal possible movements of existing statues (besides, the holographic equipment is very heavy). Statues are moved along the park perimeter. Your work is to find a renewal plan which minimizes the sum of travel distances of all statues. Installation of a new hologram adds no distance penalty, so choose the places for newcomers wisely!

Input

Input file contains two integer numbers: n — the number of holographic statues initially located at the ACM, and m — the number of statues to be added (2 ≤ n ≤ 1000, 1 ≤ m ≤ 1000). The length of the alley along the park perimeter is exactly 10 000 feet.

Output

Write a single real number to the output file — the minimal sum of travel distances of all statues (in feet). The answer must be precise to at least 4 digits after decimal point.

Sample Input

sample input #1
2 1

sample input #2
2 3

sample input #3
3 1

sample input #4
10 10

Sample Output

sample output #1
1666.6667

sample output #2
1000.0

sample output #3
1666.6667

sample output #4
0.0

Hint

Pictures show the first three examples. Marked circles denote original statues, empty circles denote new equidistant places, arrows denote movement plans for existing statues.

蓝书上的一道题。书上有错。

题意:10000长的圆周上,n个墓碑均布,现在加入了m个新的墓碑,需要移动旧墓碑使得n+m个墓碑均布,求最小的总移动距离。
题解:这题的巧妙的处理是缩小了坐标轴,使得新坐标就是整数,将老坐标向四舍五入的方向移动,就可以了。
通过这题学习了四舍五入的特殊用法。对解决最小变化量的问题很有启发。

而且,以为新坐标间隔是1,所以老坐标距离大于一,所以不会四舍五入到同一个数上去。


#include <iostream>
#include<cstdio>
#include<cmath>
using namespace std;

int main()
{
	int n,m,i;
	double pos,ans;
	scanf("%d%d",&n,&m);
	for(i=1;i<n;i++){
		pos=((double)i)/n*(n+m);
		ans+=fabs(pos-floor(pos+0.5));
	}
	printf("%.4f\n",ans*10000/(n+m));//书上少了n+m
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值