POJ 3154 Graveyard 添加m个雕塑后仍旧使每个雕塑在圆圈上距离相等 需要移动的最小距离

原题传送:http://poj.org/problem?id=3154

Graveyard
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 1086 Accepted: 555 Special Judge

Description

Programming contests became so popular in the year 2397 that the governor of New Earck — the largest human-inhabited planet of the galaxy — opened a special Alley of Contestant Memories (ACM) at the local graveyard. The ACM encircles a green park, and holds the holographic statues of famous contestants placed equidistantly along the park perimeter. The alley has to be renewed from time to time when a new group of memorials arrives.

When new memorials are added, the exact place for each can be selected arbitrarily along the ACM, but the equidistant disposition must be maintained by moving some of the old statues along the alley.

Surprisingly, humans are still quite superstitious in 24th century: the graveyard keepers believe the holograms are holding dead people souls, and thus always try to renew the ACM with minimal possible movements of existing statues (besides, the holographic equipment is very heavy). Statues are moved along the park perimeter. Your work is to find a renewal plan which minimizes the sum of travel distances of all statues. Installation of a new hologram adds no distance penalty, so choose the places for newcomers wisely!

Input

Input file contains two integer numbers: n — the number of holographic statues initially located at the ACM, andm — the number of statues to be added (2 ≤ n ≤ 1000, 1 ≤ m ≤ 1000). The length of the alley along the park perimeter is exactly 10 000 feet.

Output

Write a single real number to the output file — the minimal sum of travel distances of all statues (in feet). The answer must be precise to at least 4 digits after decimal point.

Sample Input

sample input #1
2 1

sample input #2
2 3

sample input #3
3 1

sample input #4
10 10

Sample Output

sample output #1
1666.6667

sample output #2
1000.0

sample output #3
1666.6667

sample output #4
0.0

Hint

Pictures show the first three examples. Marked circles denote original statues, empty circles denote new equidistant places, arrows denote movement plans for existing statues.

Source


题意:


一个周长为10000的圆圈,一开始等距的安放着N个雕塑,现在想增加M个雕塑,使得雕塑之间还是等距,问坟墓最少移动的距离?

#include <cstdio>
#include <cmath>
using namespace std;

int main()
{
   int n,m;
   while(~scanf("%d%d",&n,&m))
   {
       double ans(0);
       for(int i=1;i!=n;++i)
       {
           double pos=(double)i/n*(n+m);//第i个点 在n+m长度的数轴上的对应位置
           ans+=fabs(pos-floor(pos+0.5))/(n+m);//放缩坐标系   floor(pos+0.5))/(n+m) 找到离这个对应坐标的最近一个点 取得距离   累加移动距离
       }
       printf("%.4f\n",ans*10000);
   }
   return 0;
}

另外一种方法:

思路复制来自 http://www.cnblogs.com/huangfeihome/archive/2012/11/02/2750895.html


模型转换一下,把圆形的路从某个雕塑处剪开拉成一条直线,这样就很容易处理出添加雕塑前后的位置数组a[N]和c[N+M]。对于原状态的一个雕塑a[i],在新位置数组c[N+M]中找出小于等于a[i]的位置c[j],然后取位置j和其相邻两点j-1、j+1(如果有的话)距离的最小值(a[i] - min(c[j-1], c[j], c[j+1]))为a[i]须移动的最短距离。

  原来想的时候会顾虑这样一个问题:在原来的位置数组a[N]中会不会出现相邻的两个点a[i],a[i+1]同时和c[j]距离最近,也就是说上述思想会不会导致a[i]和a[i+1]移到同一个位置?其实是不会出现这种情况的,可以画个数轴分析一下,如果雕塑增多了,那么原来雕塑肯定在新位置数组的两点之间,如果同时位于中点,上述分析显然成立,如果不同时位于中点,那么,便会偏向同一侧而不会取这两点中间的c[j]。


 #include <stdio.h>
 #include <string.h>
 #include <math.h>
 #include <algorithm>
 using namespace std;
 #define N 1005
 using namespace std;
 int n, m;
 double a[N], c[N * 2];
 double  mmin(double aa,double bb)
 {
	 if(aa<bb) return aa;
	 return bb;
 }
 int main()
 {
     int i;
     double j, d, ans,mm;
     while(scanf("%d%d", &n, &m) == 2)
     {
         for(i = 0; i < n; i ++)
             a[i]=i*1.0/(double)n;
         for(i = 0;i < n + m; i ++)
             c[i] =i*1.0/(double)(n+m);
 
         double k;
         for(ans = 0.0, i = 0; i < n; i ++)
         {
			 int k;
			 for(k=0;k<n+m;k++)
			 {
                 if(a[i]<=c[k]) break;
			 }
             int loc =k;
             mm = fabs(a[i] - c[loc]);
             if(loc > 0)
                mm = mmin(mm, fabs(a[i] - c[loc - 1]));
             if(loc < n + m - 1)
                mm= mmin(mm, fabs(a[i] - c[loc + 1]));
             ans += mm;
         }
         printf("%.4f\n", ans*10000);
     }
     return 0;
 }





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值