poj 2115 C Looooops

C Looooops
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24118 Accepted: 6699

Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

Source

意不难理解,只是利用了 k位存储系统 的数据特性进行循环。

例如int型是16位的,那么int能保存2^16个数据,即最大数为65535(本题默认为无符号),

当循环使得i超过65535时,则i会返回0重新开始计数

如i=65534,当i+=3时,i=1

其实就是 i=(65534+3)%(2^16)=1

 

有了这些思想,设对于某组数据要循环x次结束,那么本题就很容易得到方程:

x=[(B-A+2^k)%2^k] /C

即 Cx=(B-A)(mod 2^k)  此方程为 模线性方程,本题就是求X的值。


#include <iostream>
#include <stdio.h>
#include <map>
#include <iomanip>

using namespace std;

long long int p[35];
void er()
{
    p[0]=1;
    for(int i=1; i<=32; i++)
    {
        p[i]=p[i-1]<<1;
    }
    //printf("%lld\n",p[32]);
}
long long int exgcd(long long int a,long long int b,long long int &x,long long int &y)
{
     if(b==0)
     {
         x=1;
         y=0;
         return a;
     }
     else
     {
        long long int tmp=exgcd(b,a%b,x,y);
         long long int t=x;
         x=y;
         y=t-a/b*y;
         return tmp;
	}
}
int main()
{
    er();
    long long int a,b,c,k;
    while(~scanf("%lld%lld%lld%lld",&a,&b,&c,&k))
    {
        if(!a&&!b&&!c&&!k)break;
                                 <span style="color:#ff0000;">//</span>x=[(B-A+2^k)%2^k] /C;
                                 //xC=(B-A)MOD2^k;
		long long int A=c;
		long long int B=b-a;
		long long int x,y;
		long long int d=exgcd(A,p[k],x,y);
        if(B%d!=0)printf("FOREVER\n");
        else
        {
           long long int t=B/d;
           x=(x*t)%p[k];
           long long int tt=p[k]/d;
           x=(x%tt+tt)%tt;
           printf("%lld\n",x);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值