C Looooops
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 27800 | Accepted: 7915 |
Description
A Compiler Mystery: We are given a C-language style for loop of type
I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k.
for (variable = A; variable != B; variable += C) statement;
I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k.
Input
The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2
k) are the parameters of the loop.
The input is finished by a line containing four zeros.
The input is finished by a line containing four zeros.
Output
The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.
Sample Input
3 3 2 16 3 7 2 16 7 3 2 16 3 4 2 16 0 0 0 0
Sample Output
0 2 32766 FOREVER
题意:给定for循环
for (variable = A; variable != B; variable += C)
其中运算都是要模2^k,即variable每次都要模2^k。求一共要循环多少次。
解析:将这个循环可以整理成(A + x*C) % 2^k = B,进一步推得A + x*C = B + y*2^k,移项得x*C - y*2^k = B-A,即方程ax +by = c的形式,用拓展欧几里德解方程即可。
代码:
#include <stdio.h>
typedef long long ll;
ll exgcd(ll a, ll b, ll &x, ll &y){
ll t, d;
if(b == 0){
x = 1;
y = 0;
return a;
}
d = exgcd(b, a%b, x, y);
t = x;
x = y;
y = t - (a/b)*y;
return d;
}
int main(){
ll A, B, C, K;
while(scanf("%lld%lld%lld%lld", &A, &B, &C, &K), (A+B+C+K)){
ll a = C;
ll b =(ll) 1<<K;//该行要注意强制类型转换,WA了好几发才改过来
ll c = B - A;
ll x, y;
ll d = exgcd(a, b, x, y);
if(c % d){
printf("FOREVER\n");
continue;
}
ll z = b/d;
x = x * (c / d);
x = (x % z + z) % z;
printf("%lld\n", x);
}
}