生日悖论

I
Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%lld & %llu
Submit

Status

Practice

LightOJ 1104

uDebug
Description
Sometimes some mathematical results are hard to believe. One of the common problems is the birthday paradox. Suppose you are in a party where there are 23 people including you. What is the probability that at least two people in the party have same birthday? Surprisingly the result is more than 0.5. Now here you have to do the opposite. You have given the number of days in a year. Remember that you can be in a different planet, for example, in Mars, a year is 669 days long. You have to find the minimum number of people you have to invite in a party such that the probability of at least two people in the party have same birthday is at least 0.5.
Input
Input starts with an integer T (≤ 20000), denoting the number of test cases.
Each case contains an integer n (1 ≤ n ≤ 105) in a single line, denoting the number of days in a year in the planet.
Output
For each case, print the case number and the desired result.
Sample Input
2
365
669
Sample Output
Case 1: 22

Case 2: 30


#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
int T,biao;
int days;
int main()
{
	int cont=0,i;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&days);
		double ans=1.0;
		
		if(days==1)
		printf("Case %d: 1\n",++cont);
		else{
			for(i=1;i<=days;i++)
			{	
				ans=ans*(double)(days-i)/days;
				if(ans<=0.5){	
					biao=i;	
					break;
				}
			}
			printf("Case %d: %d\n",++cont,biao);
		}
	}
	return 0;
}//IIIIIIIIIIIII


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值