Trailing Zeroes

Trailing Zeroes (III)
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible


关键是知道怎么算一个数的阶乘有多少个0:

#include<cstdio>
#include<algorithm>
using namespace std;
#define manx 0x3f3f3f3f
int ge(int a)<span style="white-space:pre">	</span>//计算a的阶乘有多少个0;
{
	int ans=0;
	while(a!=0)
	{
		ans=ans+a/5;
		a=a/5;
	}
	return ans;
}
int main()
{
	int t,cont,i,l,r,mid;
	int n,ans;
	scanf("%d",&t);
	cont=0;
	while(t--)
	{
		scanf("%d",&n);
		l=0,r=manx;
		while(r>=l)
		{
			mid=(l+r)/2;
			if(ge(mid)>=n)
			{
				r=mid-1;
			}
			if(ge(mid)<n)
			{
				l=mid+1;
			}
		}
		if(ge(l)==n)
		printf("Case %d: %d\n",++cont,l);
		else
		printf("Case %d: impossible\n",++cont);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值