周赛

圆周率用acos(-1.0) 使用longlong
Time Limit:500MS Memory Limit:32768KB 64bit IO Format:%lld & %llu
Submit

Status

Practice

LightOJ 1182

uDebug
Description
Given an integer n, first we represent it in binary. Then we count the number of ones. We say n has odd parity if the number of one's is odd. Otherwise we say n has even parity. 21 = (10101)2 has odd parity since the number of one's is 3. 6 = (110)2 has even parity.

Now you are given n, we have to say whether n has even or odd parity.

Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case contains an integer n (1 ≤ n < 231).

Output
For each case, print the case number and 'odd' if n has odd parity, otherwise print 'even'.

Sample Input
2
21
6
Sample Output
Case 1: odd

Case 2: even

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
	int t,cont=0;
	long long n;
	scanf("%d",&t);
	while(t--)
	{
		long long sum=0;
		scanf("%lld",&n);
		while(n)
		{
			if(n%2!=0)
				sum++;
			n=n/2;
		}
		if(sum%2==0)
		printf("Case %d: even\n",++cont);
		else
		printf("Case %d: odd\n",++cont);
	}
	return 0;
}//AAAAAAAAAA


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值