周赛

H 圆周率用acos(-1.0) 使用longlong
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

We define b is a Divisor of a number a if a is divisible by b. So, the divisors of 12 are 1, 2, 3, 4, 6, 12. So, 12 has 6 divisors.

Now you have to order all the integers from 1 to 1000. x will come before y if

1)                  number of divisors of x is less than number of divisors of y

2)                  number of divisors of x is equal to number of divisors of y and x > y.

Input

Input starts with an integer T (≤ 1005), denoting the number of test cases.

Each case contains an integer n (1 ≤ n ≤ 1000).

Output

For each case, print the case number and the nth number after ordering.

Sample Input

5

1

2

3

4

1000

Sample Output

Case 1: 1

Case 2: 997

Case 3: 991

Case 4: 983

Case 5: 840


#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
struct node{
	int shi,jia;
}shu[1010];

void geshu()
{
	for(int i=1;i<=1000;i++)
	{
		int sum=0;
		for(int j=1;j<=i;j++)
		{
			if(i%j==0)
			sum++;
		}
		shu[i].jia=sum;
		shu[i].shi=i;
	}
}
bool cmp(node x,node y)
{
	if(x.jia==y.jia){//这里要逻辑清晰;;;; 
		return x.shi>y.shi;
	}
	else{
		return x.jia<y.jia;
	}
}

int main()
{
	int t,n,cont=0;
	scanf("%d",&t);
	geshu();
	sort(shu+1,shu+1000+1,cmp);
	while(t--)
	{
		scanf("%d",&n);
		printf("Case %d: %d\n",++cont,shu[n].shi);
	}
	return 0;
}//HHHHHHHHHH

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值