HDU 2369 尺取法

解决BruceForce因键盘损坏而面临的挑战,寻找不切换键盘布局下能连续输入的最大字符数量。利用滑动窗口算法,确定由最多m种不同字符组成的最大子串长度。
摘要由CSDN通过智能技术生成

Bruce Force’s keyboard is broken, only a few keys are still working. Bruce has figured out he can still type texts by switching the keyboard layout whenever he needs to type a letter which is currently not mapped to any of the m working keys of the keyboard.

You are given a text that Bruce wishes to type, and he asks you if you can tell him the maximum number of consecutive characters in the text which can be typed without having to switch the keyboard layout. For simplicity, we assume that each key of the keyboard will be mapped to exactly one character, and it is not possible to type other characters by combination of different keys. This means that Bruce wants to know the length of the largest substring of the text which consists of at most m different characters.

Input
The input contains several test cases, each test case consisting of two lines. The first line of each test case contains the number m (1 ≤ m ≤ 128), which specifies how many keys on the keyboard are still working. The second line of each test case contains the text which Bruce wants to type. You may assume that the length of this text does not exceed 1 million characters. Note that the input may contain space characters, which should be handled like any other character.

The last test case is followed by a line containing one zero.

Output
For each test case, print one line with the length of the largest substring of the text which consists of at most m different characters.
Sample Input
5
This can’t be solved by brute force.
1
Mississippi
0
Sample Output
7
2

尺取法:维护一个字符串的最长子序列
定义双指针,l,r,初始化为0,开始转移

#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <iostream>
#include <map>
#include <stack>
#include <cmath>
#include <vector>
using namespace std;
typedef long long ll;
const int N=1e6+5;
char s[N];
int main()
{
    int n;
    while(scanf("%d",&n)&&n)
    {
        getchar();
        gets(s);
        int len=(int)strlen(s);
        int l=0,r=0,ans=0,cnt=0;
        int vis[300];
        memset(vis,0,sizeof(vis));
        while(l<=r)
        {
            while(cnt<=n&&r<len)
            {
                vis[s[r]]++;
                if(vis[s[r]]==1)cnt++;
                r++;
            }
            if(cnt==n+1)
            {
                r--;
                vis[s[r]]--;
                cnt--;
            }
            ans=max(ans,r-l);
            if(r==len) break;
            vis[s[l]]--;
            if(!vis[s[l]])cnt--;
            l++;
        }
        printf("%d\n",ans);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值