Just a Hook——线段树区间修改

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

在这里插入图片描述
Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
Sample Input
1
10
2
1 5 2
5 9 3
Sample Output
Case 1: The total value of the hook is 24.

这一题充分给刚学线段树的我教会了初始化懒惰标记的重要性。。。

#include<iostream>
#include<algorithm>
#include<cstring>
#include<stdio.h>
#define MAX 100005
using namespace std;
int tree[MAX * 4];
int lazy[MAX * 4];
void build(int k, int l, int r)
{
	if (l == r)
	{
		tree[k] = 1;
		return;
	}
	int m = (l + r) / 2;
	build(2 * k, l, m);
	build(2 * k + 1, m + 1, r);
	tree[k] = tree[2 * k] + tree[2 * k + 1]; 		//区间求和
}
void push_down(int k, int l, int r)
{
	int m = (l + r) / 2;
	if (lazy[k])
	{
		lazy[2 * k] = lazy[k];
		lazy[2 * k + 1] = lazy[k];
		tree[2 * k] = (m - l + 1) * lazy[k];
		tree[2 * k + 1] = (r - m) * lazy[k];
		lazy[k] = 0;
	}
}
void update(int k, int left, int right, int ql, int qr, int ans)
{
	if (qr < left || right < ql)
		return;
	if (ql <= left && right <= qr)
	{
		tree[k] = (right - left + 1) * ans;
		lazy[k] = ans;
		return;
	}
	push_down(k, left, right);
	int m = (left + right) / 2;
	update(2 * k, left, m, ql, qr, ans);
	update(2 * k + 1, m + 1, right, ql, qr, ans);
	tree[k] = tree[2 * k] + tree[2 * k + 1];
}
int query(int k, int l, int r, int ql, int qr)
{
	if (qr < l || r < ql)
		return 0;
	if (ql <= l && r <= qr)
		return tree[k];
	int m = (l + r) / 2;
	int s1 = query(2 * k, l, m, ql, qr);
	int s2 = query(2 * k + 1, m + 1, r, ql, qr);
	return s1 + s2;
}
int main()
{
	int num;
	scanf("%d", &num);
	int i = 1;
	while (num--)
	{
		int n, m;
		scanf("%d%d", &n, &m);
		build(1, 1, n);
		memset(lazy, 0, MAX * 4);
		while (m--)
		{
			int x, y, z;
			scanf("%d%d%d", &x, &y, &z);
			update(1, 1, n, x, y, z);
		}
		printf("Case %d: The total value of the hook is %d.\n", i, tree[1]);
		i++;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值