STL之栈结构 例题hdu1702

(计算机术语)


栈(stack)又名堆栈,它是一种运算受限的线性表。其限制是仅允许在表的一端进行插入和删除运算。这一端被称为栈顶,相对地,把另一端称为栈底。向一个栈插入新元素又称作进栈、入栈或压栈,它是把新元素放到栈顶元素的上面,使之成为新的栈顶元素;从一个栈删除元素又称作出栈或退栈,它是把栈顶元素删除掉,使其相邻的元素成为新的栈顶元素。
学过数据结构的话,栈这一数据结构不用做太多解释了。常用操作
建栈,压入,判空,取出栈顶元素,弹出栈顶元素
代码如下
#include<iostream>
#include<stack>

using namespace std;

int main()
{
	stack<int> s;
	for(int i=1;i<=5;i++)
	{
		//压之入栈 
		s.push(i);
	}
	//判断栈是否为空 
	if(!s.empty())
	{
		for(int i=0;i<5;i++)
		{
			//取栈顶元素 
			cout<<s.top()<<endl;
			//弹出栈顶元素 
			s.pop();
		}
	}
	return 0;	
} 

结合一道例题吧,顺便把队列的例题一起放这。极其简单,就是把操作过一遍

ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7650    Accepted Submission(s): 3873


Problem Description
ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
 

Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.
 

Output
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
 

Sample Input
    
    
4 4 FIFO IN 1 IN 2 OUT OUT 4 FILO IN 1 IN 2 OUT OUT 5 FIFO IN 1 IN 2 OUT OUT OUT 5 FILO IN 1 IN 2 OUT IN 3 OUT
 

Sample Output
    
    
1 2 2 1 1 2 None 2 3
FIFO先进先出队列结构
FILO先进后出的栈结构

#include<stdio.h>
#include<stack>
#include<queue>
using namespace std;
int main()
{
	int cas,i,j,n,m;
	char s[10];
	scanf("%d",&cas);
	while(cas--)
	{
          scanf("%d %s",&n,s);
		  if(s[2]=='F')
		  {
              queue<int>que;
			  for(i=0;i<n;i++)
			  {
                  scanf("%s",s);
				  if(s[0]=='I')
				  {
					  scanf("%d\n",&m);
					  que.push(m);
				  }
				  else
				  {
					  if(que.empty())
						  printf("None\n");
					  else 
					  {
						  printf("%d\n",que.front());
						  que.pop();
					  }
				  }
			  }
		  }
		  else
		  {
			 stack<int>sta;
			 for(i=0;i<n;i++)
			  {
                  scanf("%s",s);
				  if(s[0]=='I')
				  {
					  scanf("%d\n",&m);
					  sta.push(m);
				  }
				  else
				  {
					  if(sta.empty())
						  printf("None\n");
					  else 
					  {
						  printf("%d\n",sta.top());
						  sta.pop();
					  }
				  }
			  }

		  }
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值