POJ 1273 网络流最大流 题解

Drainage Ditches

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 74021 Accepted: 28789

Description

Every time it rains on Farmer John’s fields, a pond forms over Bessie’s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie’s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

Source

USACO 93

【解题报告】
题目大意:最大流的裸题。
思路,增广路算法。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
#define N 205
#define inf 0x7fffffff

int n,m;
int max_flow;//最大流 
int map[N][N],flow[N][N];//容量和流量
int res[N],pre[N];//剩余流量和父亲

int EK(int st,int ed)
{
    max_flow=0;
    queue<int>q;
    while(!q.empty()) q.pop();
    memset(flow,0,sizeof(flow));//一开始每条边的流量是0 
    for(;;)
    {
        memset(res,0,sizeof(res));//残余流量0 
        res[st]=inf;//源点的剩余流量无限 
        q.push(st);//BFS找增广路 
        int u,v;
        while(!q.empty())
        {
            u=q.front();
            q.pop();
            for(v=1;v<=m;v++)//遍历所有的边 
            {
                if(!res[v]&&map[u][v]>flow[u][v])
                {
                    pre[v]=u;
                    q.push(v);
                    res[v]=min(res[u],map[u][v]-flow[u][v]);
                }
            }
        }
        if(!res[ed]) return max_flow;//没有残余流量,即为最大流 
        for(u=ed;u!=st;u=pre[u])//还能增广,回溯,从汇点往回更新走过的边 
        {
            flow[pre[u]][u]+=res[ed];//正向 
            flow[u][pre[u]]-=res[ed];//反向 
        }
        max_flow+=res[ed];
    }
} 
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(pre,0,sizeof(pre));
        memset(map,0,sizeof(map));
        int u,v,w;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            map[u][v]+=w;
        }
        printf("%d\n",EK(1,m));
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值