HDU 3652 数位DP 解题报告

B-number

Problem Description

A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string “13” and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.

Input

Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).

Output

Print each answer in a single line.

Sample Input

13
100
200
1000

Sample Output

1
1
2
2

【解题报告】
这是机房模拟ACM的A题,然而只有我一个人做了。。。
关于不能出现13的部分就非常显然了,重点就在整除上面,因为如果直接判断的话肯定是没法转移的,所以大概思路就是记录这个数除13的余数,(DP多加一维,dfs的时候加几句就可以了)。

代码如下:

#include<cstdio>  
#include<cstring>  
#include<algorithm>  
using namespace std;  

int n;  
int dp[10][15][2][10],a[10];  

int dfs(int pos,int mod,int t,int pre,int limit)  
{  
    if(pos==-1)return (mod==0&&t);  
    if(!limit&&dp[pos][mod][t][pre]!=-1)return dp[pos][mod][t][pre];  
    int up=limit?a[pos]:9;  
    int ans=0;  
    for(int i=0;i<=up;++i)  
    {  
        ans+=dfs(pos-1,(mod*10+i)%13,t||(pre==1&&i==3),i,limit&&(i==up));  
    }  
    if(!limit) dp[pos][mod][t][pre]=ans;  
    return ans;  
}  
int solve(int x)  
{  
    int len=0;  
    while(x)  
        a[len++]=x%10,x/=10;  
    return dfs(len-1,0,0,0,1);  
}  

int main()  
{   
    memset(dp,-1,sizeof(dp));  
    while(scanf("%d",&n)!=EOF)  
    {  
        printf("%d\n",solve(n));  
    }  
    return 0;  
}  
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值