3211: 花神游历各国
Description
Input
Output
每次x=1时,每行一个整数,表示这次旅行的开心度
Sample Input
4
1 100 5 5
5
1 1 2
2 1 2
1 1 2
2 2 3
1 1 4
Sample Output
101
11
11
HINT
对于100%的数据, n ≤ 100000,m≤200000 ,data[i]非负且小于10^9
【解题报告】
根号是不支持区间修改的,于是我们选择单点修改区间查询的树状数组,但是这样是O(n^2)的
我们发现一个int范围内的数最多只要开6次根号就会变为1
但是单次修改怎么办?我们维护一个并查集,一旦一个数为1或0,我们就把这个位置的father设为它右面的那个位置即可 这样可以均摊O(n)时间找到一个数后面第一个>1的数
代码如下
/**************************************************************
Problem: 3211
User: onepointo
Language: C++
Result: Accepted
Time:1456 ms
Memory:5440 kb
****************************************************************/
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
#define N 100010
#define LL long long
#define lowbit(x) (x&(-x))
int n,m,a[N],fa[N];
LL c[N];
int find(int x)
{
return (fa[x]==x||!fa[x])?x:fa[x]=find(fa[x]);
}
void update(int x,int y)
{
while(x<=n)
{
c[x]+=y;
x+=lowbit(x);
}
}
LL query(int x)
{
LL ret=0;
while(x)
{
ret+=c[x];
x-=lowbit(x);
}
return ret;
}
void modify(int l,int r)
{
for(int i=find(l);i<=r;i=find(i+1))
{
int tmp=(int)sqrt(a[i]);
update(i,tmp-a[i]);
a[i]=tmp;
if(a[i]<=1) fa[i]=find(i+1);
}
}
int main()
{
scanf("%d",&n);
for(int i=1;i<=n;++i)
{
scanf("%d",&a[i]);
if(a[i]<=1) fa[i]=i+1;
update(i,a[i]);
}
scanf("%d",&m);
for(int i=1;i<=m;++i)
{
int opt,l,r;
scanf("%d%d%d",&opt,&l,&r);
if(opt==1)
{
printf("%lld\n",query(r)-query(l-1));
}
if(opt==2)
{
modify(l,r);
}
}
return 0;
}