POJ - 2478 Farey Sequence(欧拉筛选法)

Description
链接:http://poj.org/problem?id=2478

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}

You task is to calculate the number of terms in the Farey sequence Fn.
Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.
Output

For each test case, you should output one line, which contains N(n) —- the number of terms in the Farey sequence Fn.
Sample Input

2
3
4
5
0
Sample Output

1
3
5
9
Source

POJ Contest,Author:Mathematica@ZSU
运用直接求解会超时,所以在此运用筛选法:
对此筛选算法不理解可以先看看欧拉筛选算法了解一下:
https://blog.csdn.net/orange1710/article/details/81484322

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
typedef long long ll;
const ll MAXN = 1000005;
ll n,ans;
ll a[MAXN];
void eular()
{
    memset(a,0,sizeof(a));
    a[1] = 1;
    for(ll i=2; i<MAXN; i++){
        if(!a[i]){
            for(ll j=i; j<MAXN; j+=i){
                if(!a[j]) 
                    a[j] = j;
                a[j] = a[j]/i*(i-1);
            }
        }
    }
}
int main()
{
    eular();
    while(scanf("%lld",&n) && n)
    {
        ans=0;
        for(ll i=2;i<=n;i++) ans += a[i];
        printf("%lld\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值