抓牛---题解

Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

总结: 1、bfs
2、注意,在0这个位置跳到它的二倍位置时,步数是不变的。

代码:

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <cstring>
#include <queue>
#define MAXN 200005
using namespace std;
int n,k,num;
int line[MAXN];

int BFS(int orign)
{
    queue<int> Q;
    int temp;
    Q.push(orign);
    while(!Q.empty())
    {
        temp=Q.front();
        Q.pop();
        if(temp-1>=0&&line[temp-1]==0)
        {
            line[temp-1]=line[temp]+1;
            if(temp-1==k)
            {
                printf("%d\n",line[k]);
                break;
            }
            Q.push(temp-1);
        }
        if(temp+1<MAXN&&line[temp+1]==0)
        {
            line[temp+1]=line[temp]+1;
            if(temp+1==k)
            {
                printf("%d\n",line[k]);
                break;
            }
            Q.push(temp+1);
        }
        if(temp!=0&&temp*2<MAXN&&line[temp*2]==0)
        {
            line[temp*2]=line[temp]+1;
            if(temp*2==k)
            {
                printf("%d\n",line[k]);
                break;
            }
            Q.push(temp*2);
        }
        if(temp==n)
            line[n]=1;
    }

}

int main()
{
    //freopen("in.txt","r",stdin);
    while(~scanf("%d%d",&n,&k))
    {
        num=0;
        memset(line,0,sizeof(line));
        if(n==k)
            printf("%d\n",0);
        else
            BFS(n);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值