FZU 2218 Simple String Problem


 Problem 2218 Simple String Problem

Accept: 161    Submit: 358
Time Limit: 2000 mSec    Memory Limit : 32768 KB

 Problem Description

Recently, you have found your interest in string theory. Here is an interesting question about strings.

You are given a string S of length n consisting of the first k lowercase letters.

You are required to find two non-empty substrings (note that substrings must be consecutive) of S, such that the two substrings don't share any same letter. Here comes the question, what is the maximum product of the two substring lengths?

 Input

The first line contains an integer T, meaning the number of the cases. 1 <= T <= 50.

For each test case, the first line consists of two integers n and k. (1 <= n <= 2000, 1 <= k <= 16).

The second line is a string of length n, consisting only the first k lowercase letters in the alphabet. For example, when k = 3, it consists of a, b, and c.

 Output

For each test case, output the answer of the question.

 Sample Input

425 5abcdeabcdeabcdeabcdeabcde25 5aaaaabbbbbcccccdddddeeeee25 5adcbadcbedbadedcbacbcadbc3 2aaa

 Sample Output

6150210

 Hint

One possible option for the two chosen substrings for the first sample is "abc" and "de".

The two chosen substrings for the third sample are "ded" and "cbacbca".

In the fourth sample, we can't choose such two non-empty substrings, so the answer is 0.

 Source

第六届福建省大学生程序设计竞赛-重现赛(感谢承办方华侨大学)

题意:给定一个字符串,从里面找两个连续的没有相同字母的子串,求他们长度相乘的最大值。

思路:先n^2状压求出所有状态的最大长度,然后再枚举第一个子串的状态,找出符合条件第二个子串的最大长度,取相乘最大值就是答案。下面给代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<queue>
#include<utility>
#include<map>
#define maxn 2005
#define inf 0x3f3f3f3f
typedef long long LL;
using namespace std;
const int mod = 1e9 + 7;
char s[maxn];
int dp[1 << 16], maxnum, ori, n, k;
void dfs(int pos, int now){
	if (pos == k){
		maxnum = max(maxnum, dp[now]);
		return;
	}
	dfs(pos + 1, now);
	if ((1 << pos)&ori)
		return;
	dfs(pos + 1, now | (1 << pos));
}
int main(){
	int t;
	scanf("%d", &t);
	while (t--){
		scanf("%d%d%s", &n, &k, s);
		memset(dp, 0, sizeof(dp));
		for (int i = 0; i < n; i++){
			int now = 0;
			for (int j = i; j < n; j++){
				now |= 1 << (s[j] - 'a');
				dp[now] = max(dp[now], j - i + 1);
			}
		}
		int ans = 0;
		for (int i = 1; i < (1 << k); i++){
			if (dp[i]){
				ori = i;
				maxnum = 0;
				dfs(0, 0);
				ans = max(ans, maxnum*dp[i]);
			}	
		}
		printf("%d\n", ans);
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值