hdu4280 Island Transport (网络流最大流)&(dinic算法模板)


Island Transport

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 7591    Accepted Submission(s): 2387


Problem Description
  In the vast waters far far away, there are many islands. People are living on the islands, and all the transport among the islands relies on the ships.
  You have a transportation company there. Some routes are opened for passengers. Each route is a straight line connecting two different islands, and it is bidirectional. Within an hour, a route can transport a certain number of passengers in one direction. For safety, no two routes are cross or overlap and no routes will pass an island except the departing island and the arriving island. Each island can be treated as a point on the XY plane coordinate system. X coordinate increase from west to east, and Y coordinate increase from south to north.
  The transport capacity is important to you. Suppose many passengers depart from the westernmost island and would like to arrive at the easternmost island, the maximum number of passengers arrive at the latter within every hour is the transport capacity. Please calculate it.
 

Input
  The first line contains one integer T (1<=T<=20), the number of test cases.
  Then T test cases follow. The first line of each test case contains two integers N and M (2<=N,M<=100000), the number of islands and the number of routes. Islands are number from 1 to N.
  Then N lines follow. Each line contain two integers, the X and Y coordinate of an island. The K-th line in the N lines describes the island K. The absolute values of all the coordinates are no more than 100000.
  Then M lines follow. Each line contains three integers I1, I2 (1<=I1,I2<=N) and C (1<=C<=10000) . It means there is a route connecting island I1 and island I2, and it can transport C passengers in one direction within an hour.
  It is guaranteed that the routes obey the rules described above. There is only one island is westernmost and only one island is easternmost. No two islands would have the same coordinates. Each island can go to any other island by the routes.
 

Output
  For each test case, output an integer in one line, the transport capacity.
 

Sample Input
  
  
2 5 7 3 3 3 0 3 1 0 0 4 5 1 3 3 2 3 4 2 4 3 1 5 6 4 5 3 1 4 4 3 4 2 6 7 -1 -1 0 1 0 2 1 0 1 1 2 3 1 2 1 2 3 6 4 5 5 5 6 3 1 4 6 2 5 5 3 6 4
 

Sample Output
  
  
9 6
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   4277  4267  4268  4269  4270 

这又是一道网络流最大流裸题,不过时间卡得有点毒。。需要优化一下细节(见代码)
#include <map>
#include <set>
#include <cmath>
#include <queue>
#include <vector>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
typedef long long LL;
const int maxn = 1e5 + 10;
const int INF = 0x3f3f3f3f;
int cas = 1, T;
int d[maxn], cur[maxn], start, tend;
struct node
{
	int to, cap, next;
	//node(){}
	//node(int a,int b,int c):to(a),cap(b),rev(c){}
}edge[maxn << 1];
//vector<node>mp[maxn];
int head[maxn];
bool vis[maxn];
int cnt;
void addedge(int start, int to, int cap)
{
	edge[cnt].to = to;
	edge[cnt].cap = cap;
	edge[cnt].next = head[start];
	head[start] = cnt++;
}
bool BFS()
{
	//memset(vis,false,sizeof(vis));
	memset(d, -1, sizeof(d));
	int Q[maxn * 2];
	int Thead, Ttail;
	Thead = Ttail = 0;
	Q[Ttail++] = start;;
	d[start] = 0;
	//vis[start]=1;
	while (Thead<Ttail)
	{
		int x = Q[Thead];
		if (x == tend)return true;
		for (int i = head[x]; i != -1; i = edge[i].next)
		{
			int temp = edge[i].to;
			if (d[temp] == -1 && edge[i].cap>0)//没有标记,且可行流大于0
			{
				//vis[temp.to]=true;
				d[temp] = d[x] + 1;
				Q[Ttail++] = temp;
			}
		}
		Thead++;
	}
	return false;//汇点是否成功标号,也就是说是否找到增广路
}
int DFS(int x, int cap)
{
	if (x == tend)return cap;
	//vis[start]=true;
	int flow = 0, f;
	for (int i = head[x]; i != -1; i = edge[i].next)
	{
		int temp = edge[i].to;
		//if(temp.cap<=0||vis[temp.to])continue;
		if (d[temp] == d[x] + 1 && edge[i].cap)
		{
			f = DFS(temp, min(cap - flow, edge[i].cap));
			edge[i].cap -= f;
			edge[i ^ 1].cap += f;
			flow += f;
			if (flow == cap)break;
		}
	}
	if (!flow)d[x] = -2;//防止重搜
	return flow;
}
int maxflow()
{
	int flow = 0, f;
	while (BFS())
	{
		//memset(vis,false,sizeof(vis));
		while ((f = DFS(start, INF))>0)
			flow += f;
	}
	return flow;
}
int main()
{
	int n, m;
	scanf("%d", &T);
	while (T--)
	{
		scanf("%d%d", &n, &m);
		cnt = 0;
		memset(head, -1, sizeof(head));
		int x, y, u, v, w;
		//for(int i=0;i<n;i++)mp[i].clear();
		int tmax = -INF, tmin = INF;
		start = tend = 1;
		for (int i = 1; i <= n; i++)
		{
			scanf("%d%d", &x, &y);
			if (x <= tmin)start = i, tmin = x;
			if (x >= tmax)tend = i, tmax = x;
		}
		while (m--)
		{
			scanf("%d%d%d", &u, &v, &w);
			addedge(u, v, w);
			addedge(v, u, w);
		}
		int ans = maxflow();
		printf("%d\n", ans);
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值