2018 ICPC 北京赛区网络赛 A Saving Tang Monk II 分层 bfs

http://hihocoder.com/problemset/problem/1828

时间限制:1000ms

单点时限:1000ms

内存限制:256MB

描述

《Journey to the West》(also 《Monkey》) is one of the Four Great Classical Novels of Chinese literature. It was written by Wu Cheng'en during the Ming Dynasty. In this novel, Monkey King Sun Wukong, pig Zhu Bajie and Sha Wujing, escorted Tang Monk to India to get sacred Buddhism texts.

During the journey, Tang Monk was often captured by demons. Most of demons wanted to eat Tang Monk to achieve immortality, but some female demons just wanted to marry him because he was handsome. So, fighting demons and saving Monk Tang is the major job for Sun Wukong to do.

Once, Tang Monk was captured by the demon White Bones. White Bones lived in a palace and she cuffed Tang Monk in a room. Sun Wukong managed to get into the palace, and he wanted to reach Tang Monk and rescue him.

The palace can be described as a matrix of characters. Different characters stand for different rooms as below:

'S' : The original position of Sun Wukong

'T' : The location of Tang Monk

'.' : An empty room

'#' : A deadly gas room.

'B' : A room with unlimited number of oxygen bottles. Every time Sun Wukong entered a 'B' room from other rooms, he would get an oxygen bottle. But staying there would not get Sun Wukong more oxygen bottles. Sun Wukong could carry at most 5 oxygen bottles at the same time.

'P' : A room with unlimited number of speed-up pills. Every time Sun Wukong entered a 'P' room from other rooms, he would get a speed-up pill. But staying there would not get Sun Wukong more speed-up pills. Sun Wukong could bring unlimited number of speed-up pills with him.

Sun Wukong could move in the palace. For each move, Sun Wukong might go to the adjacent rooms in 4 directions(north, west,south and east). But Sun Wukong couldn't get into a '#' room(deadly gas room) without an oxygen bottle. Entering a '#' room each time would cost Sun Wukong one oxygen bottle.

Each move took Sun Wukong one minute. But if Sun Wukong ate a speed-up pill, he could make next move without spending any time. In other words, each speed-up pill could save Sun Wukong one minute. And if Sun Wukong went into a '#' room, he had to stay there for one extra minute to recover his health.

Since Sun Wukong was an impatient monkey, he wanted to save Tang Monk as soon as possible. Please figure out the minimum time Sun Wukong needed to reach Tang Monk.

输入

There are no more than 25 test cases.

For each case, the first line includes two integers N and M(0 < N,M ≤ 100), meaning that the palace is a N × M matrix.

Then the N×M matrix follows.

The input ends with N = 0 and M = 0.

输出

For each test case, print the minimum time (in minute) Sun Wukong needed to save Tang Monk. If it's impossible for Sun Wukong to complete the mission, print -1

样例输入

2 2
S#
#T
2 5
SB###
##P#T
4 7
SP.....
P#.....
......#
B...##T
0 0

样例输出

-1
8
11

题意不解释了 很简单。

题解:和以往的bfs最短路不同,本题中每个点都可以重复走,要找到能到达终点的最短路。关键在于氧气的数量最多为5个。

那么vis数组可以增加一维记录氧气数量分别为0,1,2,3,4,5时的状态(为什么?比如当氧气数量为3时,所有氧气数量为3的状态的点都没有一条能够到达终点的路径,那么氧气数量为3就是一个无效状态,所以要用一个vis数组标记这些状态防止再次遍历),用一个优先队列记录所有状态下的最小步数就行了。


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<stdio.h>
#include<string.h>
#include<queue>
#include<cmath>
#include<map>
#include<set>
#include<vector> 
using namespace std;
#define inf 1e18
#define rep(i,a,n) for(int i=a;i<=n;i++)
#define per(i,a,n) for(int i=n;i>=a;i--)
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
#define mem(a,b) memset(a,b,sizeof(a));
#define lowbit(x)  x&-x;
typedef long long ll;
const int mx = 105;
struct node{
	int x,y;
	int step;
	int b;
	node(){}
	node(int x1,int y1,int st,int bb):	x(x1),y(y1),step(st),b(bb){}
	bool operator < (const node &C)const{
		return step > C.step;
	}
};
int n,m;
char mp[mx][mx];
int vis[mx][mx][6];
int dis[4][2] = {1,0,-1,0,0,1,0,-1};
int stx,sty;
int bfs(){
	mem(vis,0);
	priority_queue<node>q;
	while(!q.empty()) q.pop();
	node cur,nxt;
	vis[stx][sty][0] = 1;
	q.push(node(stx,sty,0,0));
	while(!q.empty()){
		cur = q.top();
		q.pop();
		if(mp[cur.x][cur.y] == 'T') return cur.step;
		for(int i = 0; i < 4; i++){
			int nx = cur.x + dis[i][0];
			int ny = cur.y + dis[i][1];
			if(nx < 0 || nx >= n || ny < 0 || ny >= m) continue;
			nxt.x = nx, nxt.y = ny, nxt.b = cur.b;
			if(mp[nx][ny] == 'P'){
				if(!vis[nxt.x][nxt.y][nxt.b]){
					vis[nxt.x][nxt.y][nxt.b] = 1;
					nxt.step = cur.step; 
					q.push(nxt);
				}
			}
			else if(mp[nx][ny] == 'B'){
				nxt.b = min(5, cur.b+1);
				nxt.step = cur.step + 1;
				if(!vis[nxt.x][nxt.y][nxt.b]){
					vis[nxt.x][nxt.y][nxt.b] = 1;
					q.push(nxt);
				}
			}
			else if(mp[nx][ny] == '#'){
				if(!cur.b) continue;
				nxt.b = cur.b - 1;
				nxt.step = cur.step + 2;
				if(!vis[nxt.x][nxt.y][nxt.b]){
					vis[nxt.x][nxt.y][nxt.b] = 1;
					q.push(nxt); 
				} 
			}
			else{
				nxt.step = cur.step + 1;
				if(!vis[nxt.x][nxt.y][nxt.b]){
					vis[nxt.x][nxt.y][nxt.b] = 1;
					q.push(nxt); 
				} 
			}
		}
	}
	return -1;
}
int main(){
	while(~scanf("%d%d",&n,&m)){
		if(!n && !m) break; 
		for(int i = 0; i < n; i++){
			getchar();
			for(int j = 0; j < m; j++){
				scanf("%c",&mp[i][j]);
				if(mp[i][j] == 'S'){
					stx = i,sty = j;
				}
			}
		}
		int ans = bfs();
		printf("%d\n",ans);
	}
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值