背包dp之分组背包

题目链接:

hdu1712


题意:

题目大意:ACboy要开始选课了,上一门课能够获得的收益和他上这门课的时间是有关的,然后给你若干门课,让你帮他进行选课,每一门课只能选择一个课程时长,问你如何选择,才能使ACboy获得的受益最大。


题目输入输出:

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.

Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.

Sample Input
2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0

Sample Output
3
4
6


思路:

思路分析:将这道题抽象一下,背包容量相当于ACboy拥有的时间,然后给你若干组物品(课程),每一组物品里面有着若干个物品(课程时间),一组里面的物品只能选择一个,这么一抽象,标准的分组背包问题,相当于若干组物品的01背包
问题,但是要注意,v的循环一定要放在组内物品循环之外,这样才能保证一个组的物品只用了一个,另外,内层循环要有一个判断,判断是否满足v-cost>=0,否则会出现数组越界,报错。(一共三重循环)


代码:

#include <stdio.h>
int max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int n,m;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)break;
        int i,j,k;
        int a[102][102];
        int dp[102]={0};
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
            {
                scanf("%d",&a[i][j]);
            }
        }
        for(i=1;i<=n;i++)
        {
            for(j=m;j>=0;j--)
            {
                for(k=1;k<=j;k++)
                {
                    dp[j]=max(dp[j],dp[j-k]+a[i][k]);
                }
            }
        }
        printf("%d\n",dp[m]);
    }
    return 0;   
} 
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值