hdu 5929 Basic Data Structure (双端队列)

Basic Data Structure

Time Limit: 7000/3500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 260    Accepted Submission(s): 62


Problem Description
Mr. Frog learned a basic data structure recently, which is called stack.There are some basic operations of stack:

 PUSH x: put x on the top of the stack, x must be 0 or 1.
 POP: throw the element which is on the top of the stack.

Since it is too simple for Mr. Frog, a famous mathematician who can prove "Five points coexist with a circle" easily, he comes up with some exciting operations:

REVERSE: Just reverse the stack, the bottom element becomes the top element of the stack, and the element just above the bottom element becomes the element just below the top elements... and so on.
QUERY: Print the value which is obtained with such way: Take the element from top to bottom, then do  NAND operation one by one from left to right, i.e. If   atop,atop1,,a1  is corresponding to the element of the Stack from top to the bottom,  value=atop  nand  atop1  nand ... nand  a1 . Note that the Stack  will notchange after QUERY operation. Specially, if the Stack is empty now,you need to print ” Invalid.”(without quotes).

By the way,  NAND is a basic binary operation:

 0 nand 0 = 1
 0 nand 1 = 1
 1 nand 0 = 1
 1 nand 1 = 0

Because Mr. Frog needs to do some tiny contributions now, you should help him finish this data structure: print the answer to each QUERY, or tell him that is invalid.
 

Input
The first line contains only one integer T ( T20 ), which indicates the number of test cases.

For each test case, the first line contains only one integers N ( 2N200000 ), indicating the number of operations.

In the following N lines, the i-th line contains one of these operations below:

 PUSH x (x  must be 0 or 1)
 POP
 REVERSE
 QUERY

It is guaranteed that the current stack will not be empty while doing POP operation.
 

Output
For each test case, first output one line "Case #x:w, where x is the case number (starting from 1). Then several lines follow,  i-th line contains an integer indicating the answer to the i-th QUERY operation. Specially, if the i-th QUERY is invalid, just print " Invalid."(without quotes). (Please see the sample for more details.)
 

Sample Input
  
  
2 8 PUSH 1 QUERY PUSH 0 REVERSE QUERY POP POP QUERY 3 PUSH 0 REVERSE QUERY
 

Sample Output
  
  
Case #1: 1 1 Invalid. Case #2: 0
Hint
In the first sample: during the first query, the stack contains only one element 1, so the answer is 1. then in the second query, the stack contains 0, l

(from bottom to top), so the answer to the second is also 1. In the third query, there is no element in the stack, so you should output Invalid.

 

赛后补的题,比赛的时候TL,WA,心累,后来发现是缺少对于0的标记,扫描的话超时,栈模拟队列稳的一匹呀,然后双端队列(刚开始不懂)记录0的位置就好了,记住一定要比较0和相应尾进行比较。

还有一个规律就是如果头是0 无论后边是啥  最后结果都是1   如果奇数个1在一块进行运算最后结果也是1,偶数相反

#include<stdio.h>
#include<iostream> 
#include <algorithm>
#include<string.h>
#include<vector>
#include<math.h>
#include<queue>
#include<deque>//双端队列 
#include<set>
#define LL long long
#define INF 0x3f3f3f3f
using namespace std;
int KGCD(int a,int b){if(a==0)return b;if(b==0)return a;if(~a&1){ if(b&1) return KGCD(a>>1,b);else return KGCD(a>>1,b>>1) <<1; } if(~b & 1)  return KGCD(a, b>>1);  if(a > b) return KGCD((a-b)>>1, b);return KGCD((b-a)>>1, a);}  
int LCM(int a,int b){ return a/KGCD(a,b)*b; } 
int dir[5][2]={0,1,0,-1,1,0,-1,0};
using namespace std;
int stack[600000];
int main()
{
	int t,n,flag,x;
	char str[20];
	deque<int>d; //记录0的位置 
	scanf("%d",&t);
	for(int k=1;k<=t;k++)
	{
		d.clear();
		scanf("%d",&n);
		flag=1;
		int left=299999;
		int right=300000; 
		printf("Case #%d:\n",k);
		while(n--)
		{
			scanf("%s",str);
			if(strcmp(str,"PUSH")==0)	
			{
				scanf("%d",&x);
				if(flag)//往右走 
				{
					stack[right]=x;
					if(x==0)
						d.push_back(right);
					right++;
				}
				else//往左走 
				{
					stack[left]=x;
					if(x==0)
						d.push_front(left); 
					left--; 
				}
			}
			else if(strcmp(str,"POP")==0)
			{
				if(flag)
				{
					right--;
					if(stack[right]==0)
						d.pop_back();
				}
				else
				{
					left++;
					if(stack[left]==0)
						d.pop_front();
				}
			}
			else if(strcmp(str,"REVERSE")==0)
			{
				flag=flag^1;	
			}
			else if(strcmp(str,"QUERY")==0)
			{
				if(right-left==1)
					printf("Invalid.\n");
				else if(d.empty())//都是1 没有0  如果是空的话 
				{
					int temp=right-left-1;
					if(temp%2==0)
						printf("0\n");
					else
						printf("1\n");
				}
				else//就是看那个方向和尾巴
				{
					int num=0;
					if(flag)
					{
						int temp=d.front();
						if(temp==right-1)
							num=d.front()-left-1;
						else
							num=d.front()-left;
					} 
					else
					{
						int temp=d.back();
						if(temp==left+1)
							num=right-temp-1;
						else
							num=right-temp;	
					}
					printf("%d\n",num%2);
				}		
			}	
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值