Poj 2976 Dropping tests (01分数规划入门)

题目链接:http://poj.org/problem?id=2976

Dropping tests

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17461 Accepted: 6060

Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains npositive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

题意+想法:

给出n个物品,每个物品有两个属性a和b,选择n-k个元素,询问∑ai / ∑bi的最大值。

∑ai / ∑bi ≥ x 故 ∑ai / ∑bi ≥ x就等价于∑ai − x * ∑bi ≥ 0。

二分完把ai-x*bi排序后把最大的n-k个选出来就行了。

poj不知道抽风还是如何G++  WA  C++ AC

#include<iostream>
#include<stdio.h>
#include <algorithm>  
using namespace std;
const int MAXN = 1e5+5;
const double eps = 1e-6;
int a[MAXN];
int b[MAXN];
double c[MAXN];
int n,k;
int check(double mid)
{
	for(int i=0;i<n;i++)
		c[i]=a[i]-mid*b[i];
	sort(c,c+n);
	double ans=0;
	for(int i=k;i<n;i++)
		ans=ans+c[i];
	return ans>=0;
}
void solve()
{
	double l=0;
	double r=1;
	while(r-l>eps)
	{
		double mid = (l+r)/2;
		if(check(mid))
			l=mid;
		else
			r=mid;
	}
	printf("%.0lf\n",l*100);
}
int main()
{
	while(scanf("%d%d",&n,&k)!=EOF)
	{
		if(n==0 && k==0)
			break;
		for(int i=0;i<n;i++)
			scanf("%d",&a[i]);
		for(int i=0;i<n;i++)
			scanf("%d",&b[i]);
		solve();
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值