UVA 11538 Chess Queen

Question:
You probably know how the game of chess is played and how chess queen operates. Two chess queens
are in attacking position when they are on same row, column or diagonal of a chess board. Suppose
two such chess queens (one black and the other white) are placed on (2 × 2) chess board. They can be
in attacking positions in 12 ways, these are shown in the picture below:
Figure: in a (2 × 2) chessboard 2 queens can be in attacking position in 12 ways
Given an (N × M) board you will have to decide in how many ways 2 queens can be in attacking
position in that.
Input
Input file can contain up to 5000 lines of inputs. Each line contains two non-negative integers which
denote the value of M and N (0 < M, N ≤ 106
) respectively.
Input is terminated by a line containing two zeroes. These two zeroes need not be processed.
Output
For each line of input produce one line of output. This line contains an integer which denotes in how
many ways two queens can be in attacking position in an (M × N) board, where the values of M and
N came from the input. All output values will fit in 64-bit signed integer.
Sample Input
2 2
100 223
2300 1000
0 0
Sample Output
12
10907100
11514134000
题意大意:两个皇后放在一个n*m的矩形方阵中,两个皇后在同一水平,同一竖直,同一斜线上均会互相攻击,让你输出共有多少中方案使两个皇后互相攻击。
思路:水平的和竖直的情况非常容易考虑,但斜线就不容易想到了。我们可以先算非最长的对角线的请况,sum+=4*i*(i-1);1<=i

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
const int Max=1000005;
long long  a[Max];
int main()
{
   long long  n,m;
    while(1)
    {
        long long sum=0;
        scanf("%lld%lld",&n,&m);
        if(n==0&&m==0)
            break;
        sum+=(n*(n-1)*m+m*(m-1)*n);     //这里算的是水平和竖直的情况
        for(long long i=1;i<min(n,m);i++)
        sum+=4*i*(i-1);        //这里算的是非最长对角线的请况
        long long  t=abs(n-m),h=min(n,m);  //这里算的最长对角线的情况(当n!=m时,最长对角线不只有一条)
        sum+=2*(t+1)*h*(h-1);
        printf("%lld\n",sum);
    }
    return 0;
}

体会:把问题细化,可能就会变得简单。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值