【暴力】HRBUST 1011 THE DRUNK JAILER

THE DRUNK JAILER
Time Limit: 1000 MSMemory Limit: 65536 K
Total Submit: 626(462 users)Total Accepted: 498(450 users)Rating: Special Judge: No
Description

A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked. 
One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey,and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the 
hall locking every other cell (cells 2, 4, 6, ?). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, ?). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He 
repeats this for n rounds, takes a final drink, and passes out. 
Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape. 
Given the number of cells, determine how many prisoners escape jail.

Input

The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number of cells n.

Output

For each line, you must print out the number of prisoners that escape when the prison has n cells.

Sample Input
2
5
100
Sample Output
2
10

题目意思不难理解,有点像灯泡问题,有n个监狱,第一次打开全部的门,第二次遇到2的倍数的监狱的时候如果门开着就关上,如果关上就打开...以此类推,到第n次的时候,所有是n的被数的门当中,如果门的上一个状态是打开的就关上,关上的就打开,问你最后有多少监狱的门是打开的。
数据很水,直接暴力。

附上AC代码

#include<stdio.h>
#include<string.h>

int a[106];

void solve(void)
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        memset(a,0,sizeof(a));
        for(int i = 1 ; i <= n ; i++)
        {
            for(int j = 1 ; j <= n ; j++)
            {
                if(j%i==0)
                {
                    if(a[j]==0) a[j] = 1;
                    else a[j] = 0;
                }
            }
        }
        int ans = 0;
        for(int i = 1 ; i <= n ; i++) if(a[i]==1) ans++;
        printf("%d\n",ans);
    }
}


int main(void)
{
    solve();
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

两米长弦

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值