02-线性结构3 Reversing Linked List (25分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

题解:

思路:

1.输入的数据实际是单向链表,而观察数据处理和输出发现,原数据既没有发生数目变化,也没有发生节点数据变化,意味着输出数据只涉及查找操作。而我们知道,根据序标查找的话,链表的查询效率低下,为O[n],而数组查询效率为O[1]。所以这道题的关键是转化数据存储结构。

2.在输入时直接用节点数组存储,存储形式为Node[adress].

3.将单向链表的节点数据转变为数组存储,用一个额外的数组存储节点的地址,用以查找和转换。

4.注意输出形式。

#include <stdio.h>
using namespace std;

#define MAX 100001

typedef struct Node *List;
struct Node{
    int data;
    int next;
};
Node N[MAX];

int main(){
    int num;
    int K;
    int address,data,next;
    int L[MAX];
    scanf("%d %d %d",&address,&num,&K);
    for(int i=0;i<num;i++){
        int tempadd,tempdata,tempnext;
        scanf("%d",&tempadd);
        scanf("%d %d",&tempdata,&tempnext);
        N[tempadd].data=tempdata;
        N[tempadd].next=tempnext;       
    }
    int n=0;
    while(address!=-1){
       L[n]=address;
       n++;
       address=N[address].next;
    }
	for(int i=0;i<n-n%K;i+=K){   
		for(int j=0;j<K/2;j++){
            //反转链表  
			int t = L[i+j];
			L[i+j] = L[i+K-j-1];
			L[i+K-j-1] = t; 
		}
	}
    for(int i=0;i<n-1;i++)
	printf("%05d %d %05d\n",L[i],N[L[i]].data,L[i+1]);
	printf("%05d %d -1\n",L[n-1],N[L[n-1]]);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值