UVALive 3026 Period (KMP上的dp,学习ac自动机的前奏)

 
B - Period
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
Appoint description: 

Description

Download as PDF

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 ≤ i ≤ N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 ≤ N ≤ 1 000 000) � the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

Output

For each test case, output �Test case #� and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4


KMP上的dp问题,彻底明白kmp了,这道题脑补一下dp就出来了。

就不解释了,代码有些注释

推荐介绍kmp算法博客:http://blog.csdn.net/v_july_v/article/details/7041827


//Hello. I'm Peter.
#include<cstdio>
#include<iostream>
#include<sstream>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<functional>
#include<cctype>
#include<ctime>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
using namespace std;
typedef long long ll;
typedef long double ld;
#define peter cout<<"i am peter"<<endl
#define input freopen("data.txt","r",stdin)
#define randin srand((unsigned int)time(NULL))
#define INT (0x3f3f3f3f)*2
#define LL (0x3f3f3f3f3f3f3f3f)*2
#define gsize(a) (int)a.size()
#define len(a) (int)strlen(a)
#define slen(s) (int)s.length()
#define pb(a) push_back(a)
#define clr(a) memset(a,0,sizeof(a))
#define clr_minus1(a) memset(a,-1,sizeof(a))
#define clr_INT(a) memset(a,INT,sizeof(a))
#define clr_true(a) memset(a,true,sizeof(a))
#define clr_false(a) memset(a,false,sizeof(a))
#define clr_queue(q) while(!q.empty()) q.pop()
#define clr_stack(s) while(!s.empty()) s.pop()
#define rep(i, a, b) for (int i = a; i < b; i++)
#define dep(i, a, b) for (int i = a; i > b; i--)
#define repin(i, a, b) for (int i = a; i <= b; i++)
#define depin(i, a, b) for (int i = a; i >= b; i--)
#define pi 3.1415926535898
#define eps 1e-6
#define MOD 1000000007
#define MAXN 1001000
#define N
#define M 4
int n;
char row[MAXN];
int nextpos[MAXN];//kmp算法里的next数组,表示长度为i的串的最长前缀后缀的长度值
int dp[MAXN][2];
//dp[i][1]代表长度为i的前缀的K值是多少,即重复串出现的次数
//dp[i][0]代表重复串的长度
void build_nextpos()
{//kmp算法中求next数组的经典操作
    int i,j;
    i=0;
    j=-1;
    nextpos[0]=-1;
    while(i<n)
    {
        if(j==-1 || row[i]==row[j])
        {
            nextpos[i+1]=j+1;
            i++;
            j=j+1;
        }
        else j=nextpos[j];
    }
}
struct Answer
{
    int prefix_size;
    int k;
}ans[MAXN];
int num_ans;
int main()
{
    int j,d,kase=1;
    while(~scanf("%d",&n) && n)
    {
        scanf("%s",row);
        build_nextpos();
        num_ans=0;
        dp[0][0]=0;
        dp[0][1]=0;
        repin(i,1,n)
        {
            j=nextpos[i];
            d=i-j;
            //d表示从j开始到i的长度
            if(d==dp[j][0])
            {//如果这个长度巧好等于我前缀后缀串的重复串的长度,那么我一定是周期串
                dp[i][1]=dp[j][1]+1;
                dp[i][0]=dp[j][0];
            }
            else//如果不等于,那么我本身是一个周期串,串的个数为1,长度为本身长度
            {
                dp[i][1]=1;
                dp[i][0]=i;
            }
            //题意要求K>1的时候才算作答案输出
            if(dp[i][1]>=2)
            {
                int t=++num_ans;
                ans[t].prefix_size=i;
                ans[t].k=dp[i][1];
            }
        }
        printf("Test case #%d\n",kase++);
        repin(i,1,num_ans)
        {
            printf("%d %d\n",ans[i].prefix_size,ans[i].k);
        }
        printf("\n");
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值