Uva 10305 - Ordering Tasks

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

Input

The input will consist of several instances of the problem. Each instance begins with a line containing
two integers, 1 ≤ n ≤ 100 and m. n is the number of tasks (numbered from 1 to n) and m is the
number of direct precedence relations between tasks. After this, there will be m lines with two integers
i and j, representing the fact that task i must be executed before task j.
An instance with n = m = 0 will finish the input.

Output

For each instance, print a line with n integers representing the tasks in a possible order of execution.

Sample Input

5 4
1 2
2 3
1 3
1 5
0 0

Sample Output

1 4 2 5 3

拓扑排序的模板题。

解题思路:

  1. 读入图结构,记录每个节点的入度数(也就是有多少条边的终点为该节点)。
  2. 每次寻找入度为0的点,push_back到ans,然后寻找到的节点的入度减1(入度为-1则后续不会再被考虑),然后将该点连接的点的入度减1。这一步的目的可以理解为将入度为0的点从图中移除,将问题变为求剩下的结点的拓扑排序。
  3. 循环第二步直到所有结点均已进入ans

代码:

#include <bits/stdc++.h>
using namespace std;

const int maxn = 505;
int G[maxn][maxn];
int indegree[maxn];
int n,m,u,v;

int main(int argc, char const *argv[])
{
	while(cin >> n >> m && n != 0)
	{
		memset(indegree,0,sizeof(indegree));
		memset(G,0,sizeof(G));
		
		for(int i = 0;i < m; i++)
		{
			cin >> u >> v;
			G[u][v] = 1;
			indegree[v]++;
		}
		
		vector<int> ans;
		while(ans.size() != n)
		{
			for(int i = 1;i <= n; i++)
			{
				if(indegree[i] == 0)           
				{
					indegree[i]--;              // 将入度变为-1就不再有机会被加入ans 
					ans.push_back(i);
					for(int j = 1;j <= n; j++)   //将i连接的点的入度都减1 
						if(G[i][j])
							indegree[j]--;
				}
			}	
		}
		for(int i = 0;i < ans.size(); i++)
			cout << ans[i] << " ";
		cout << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值