LightOj 1122 Digit Count(数位dp)

Digit Count

Description

Given a set of digits S, and an integer n, you have to find how many n-digit integers are there, which contain digits that belong to S and the difference between any two adjacent digits is not more than two.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case contains two integers, m (1 ≤ m < 10) and n (1 ≤ n ≤ 10). The next line will contain m integers (from 1 to 9) separated by spaces. These integers form the set S as described above. These integers will be distinct and given in ascending order.

Output

For each case, print the case number and the number of valid n-digit integers in a single line.

Sample Input

3

3 2

1 3 6

3 2

1 2 3

3 3

1 4 6

Sample Output

Case 1: 5

Case 2: 9

Case 3: 9


解题思路:

题目大意:

给你m种数,要求使用这m种数组成n位整数,使得该数的每位和相邻位的数的差不超过2。

算法思想:

dp[i][j]表示以j结尾的i位整数的解法数目。 

dp[i][j] += dp[i-1][k] , abs(j-k) <= 2

答案即为sum(dp[n][i](1<=i<=9,且i在集合S中))

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

int a[15];
int dp[15][15];

int main(){
    int T,t = 1;
    scanf("%d",&T);
    while(T--){
        int x,m,n;
        scanf("%d%d",&m,&n);
        memset(a,0,sizeof(a));
        memset(dp,0,sizeof(dp));
        for(int i = 1; i <= m; i++){
            scanf("%d",&x);
            a[x] = 1;
        }
        for(int i = 1; i <= 9; i++){
            if(a[i])
                dp[1][i] = 1;
        }
        for(int i = 2; i <= n; i++){
            for(int j = 1;j <= 9; j++){
                if(a[j])
                    dp[i][j] = 0;
                for(int k = 1; k <= 9; k++){
                    if(a[k] && abs(j-k) <= 2)
                        dp[i][j] += dp[i-1][k];
                }
            }
        }
        int ans = 0;
        for(int i = 1; i <= 9; i++){
            if(a[i])
                ans += dp[n][i];
        }
        printf("Case %d: %d\n",t++,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值