hdu 1098

Ignatius's puzzle


Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

 

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
 

Output
The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.
 

Sample Input
 
 
111009999
 
Sample Output
 
 
22no43
 
/*
数学归纳法 
题意:方程f(x)=5*x^13+13*x^5+k*a*x 
      输入任意一个数k(k>=0&&k<10000)是否存在一个数a,对任意x都能使得f(x)被65整除。 
做法:这个题目的话肯定是有巧妙方法,思维题目
      f(x)能被65整除 说明f(x)=65*n(n为整数)
	  即 f(x)=5*x^13+13*x^5+k*a*x=65*n 
	  根据数学归纳法 令x=1 则 18+ka = 65*n 
	  只需找到一个最小的a满足 (18+ka)%65==0 即可。
      因为 k 、a 都是非负的整数 所以 a>=65的时候还没找到就输出no 
*/
#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <string>
#include <cstdlib>
using namespace std;
int main(void)
{
	int k;
	while(scanf("%d",&k)!=EOF)
	{
		int flag=0;
		for(int i=0;i<65;i++)
		{
			if((18+k*i)%65==0)
			{
				flag=1;
				printf("%d\n",i);
				break;
			}
		}
		if(flag==0) printf("no\n");
	} 
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值